Edit built-in alias, new 64-bit install, restored 32-bit config

Hi, I recently upgraded to 64-bit Windows and restored my config from my old 32-bit machine. Now all the built-in aliases refer to the (x86) folder and I can't change them. Can you help me with how to fix this?

Do you mean your Opus config, or your Windows config?

Have you installed Opus on the new machine normally, or has your old 32-bit installation of the program (not just the settings) been ported over somehow? (Or is it a portable install?)

I did a fresh install of Windows 10 (64-bit), then I downloaded and installed Opus 11.19 (64-bit). I restored an Opus backup (.ocb) from my old machine, which was 32-bit.

What you did sounds fine and should mean you're running the 64-bit version. (The built-in aliases are not stored in the configuration at all. They're part of the program.)

But the screenshot above looks like something you should only see when running the 32-bit version, which would not normally install on 64-bit Windows.

If you open Help > About Directory Opus, does it say x86 or x64 after the version number?

Another thing to check:

  • Open Task Manager
  • Details tab
  • Locate dopus.exe in the list, right-click it and choose Properties.
  • Is it running out of "C:\Program Files\GPSoftware\Directory Opus" or somewhere else?

Hi leo, the About dialog in Opus says "Version 11.19 x64", the path in Process Explorer (sysinternals) is "C:\Program Files\GPSoftware\Directory Opus", the image type is 64-bit.

Actually, I think this is just a display issue in the preferences screen. If I type in any alias in the lister e.g. /programfiles, it will correctly take me to the correct folder.

Sorry leo, I just checked the preferences again and everything looks okay, the aliases refer to the proper folders, I'm not sure if it just needed a restart, but everything seems fine now.