Elevated Command Prompt

Just recently every time I click on the diropus shortcut on the QL bar I get the UAC prompt to accept before the prog will open. I am running win7 x64, with admin priviliges and UAC is set to prompt but not dim the screen and I am running the latest version of diropus. This behaviour has not occured before and I am wondering what I can do to correct this. I have read the faq & that confused my poor brain today, done a clean reinstall but to no avail, and have not made any changes to UAC settings on my PC that would explain this behaviour. Any thoughts suggestions welcome.


Did you follow the 'How to turn off "Run as Administrator"' part of this FAQ?

Why NOT to run Opus as Administrator in Vista / Windows 7

Hi leo, Yes I did and following the reinstall I can confirm that it is not set to run in admin mode which I assume is the default installation mode?

Check that the shortcut on the QL bar is also not set to run Opus as administrator.

Cracked it! Leo I did as you suggested and no the shortcut was not set to "admin" however when I checked the "compatability" tab I found that "admin" was in fact ticked. So I changed that and on reboot got the UAC prompt for the prog and now all is sweet and light. Thanks for your input.


[Merged from separate thread]
Now every time I boot the PC it asks me if I want to elevate DirOpus, so something is still not right.

The file that permission is being souught for on start up is dopusrt.exe.

[quote="corkyboy"]Now every time I boot the PC it asks me if I want to elevate DirOpus, so something is still not right.

The file that permission is being souught for on start up is dopusrt.exe.[/quote]

dopusrt.exe must be set to run as Administrator. The steps for fixing that are the same as the ones for fixing dopus.exe.

Do you have any idea why all these run as admin flags were set? They should never be set by default so presumably it's something you've done yourself and then forgotten about?

The file does have an admin privileges, see attached grab:

Ok so maybe change that?

If I do that I will be prompted every time I use the prog, as it is I can OK it on boot up and not have to thereafter.

Why will you be prompted every time? You shouldn't be running Opus as admin at all. How are you launching it?

Hi Jon, my apologies as your suggestion has actually resolved the problem. You will notice from the screen grab that "run as admin" was greyed out. So I turned of UAC completely, rebooted, reset and then cleared dpousrt.exe to run as admin. Rebooted with UAC running and now it works correctly. Thanks mate.
PS I see you are in Melbourne and I must declare that as a POM living in NSW yesterday's events at the MCG were magnificent!



You just needed to click the "Change for all users" button at the bottom of the window in your screenshot to be able to change the setting.

I'm still wondering how the setting got there in the first place. It's not something Opus sets itself, nor something anything else would set, but presumably if you had set it yourself you would have remembered it, remembered how to undo it, and realised that was why you started getting UAC prompts?

Oh well, good that it's solved now.

Hi Leo, I had previously tried clicking on "change for all users" as you suggested but this provoked no response or change. As to how the admin rights were assigned in the first place, this was my doing when the prog started to ask for permission and I thought it might solve it. All's well that ends well.