Error 0xc000001d on old XP machine


Regarding USB export using Dopus11 on a 64bit Win7 pc:

When I either export to 32bit or both (64bit+32bit) and try to run Dopus on a 32bit XP pc from the USB stick I get an error message not being able to initialize.

I never tried it with the previous Dopus10 since I added USB functionality when upgrading.

Is this a common issue with perhaps known solutions?

While I'm here anyway: is it allowed to install my older Dopus10 on a second computer instead of trashing the license?


Does it run on the PC where you exported DO (exit installed DO - not just closing all listers - and run USB-DO)?

No, you need a full license for each PC (you're allowed to use each license also on 1 laptop/tablet), so an upgraded license is the same and cancels the older one (DO v10 will run with your v11 license).

What's the exact error message?


Running dopus on the initial pc (on which I created the USB export) it indeed works ok.
Still having the 32-bits export on the flash drive I just tried again on the 32bit XP machine: still the error showing up.
I have to OK-click OK two of those exact same error messages away until I'm back in the Windows explorer window.
Attached a screendump of the error message.

Update: just tested on a Win7 laptop and 32bit Dopus runs fine from the USB drive.

Anything I need to install in XP first perhaps?


What's the CPU on the XP machine? An old AMD one by any chance?

(I'm guessing it's due to the newer compiler from Microsoft requiring SSE2 by default in the code it generates: ... =6&t=31782 )

Assuming the issue was due to a very old AMD CPU lacking SSE2 support, if you re-download the installer now you should find it works on that machine.

We've recompiled the 32-bit version so it no longer requires SSE2.

Wow, Leo,

First guess, right guess :sunglasses:
Indeed it's an AMD Athlon XP 3200+ processor of the pre-SSE2 era, so véry, véry, véry old still wooden circuitry with flintstone registers embedded in amber housing (hmm, how old am I then?) :thumbsup:

You were a bit fast with already "fixing" the installer before even having begot any confirmation of the processor type!
Good news is: it's working now!

USB stick contains both 32bit and 64bit :opusicon: and it's working on the 64-bit Win7 mother pc, the older 32bit XP (AMD) pc as well as on a 64bit Win7 laptop.
If possible the 64bit version is being chosen automatically and otherwise the 32bit version; works like a charm!

Thanks for the help and fix :opussanta: Leo !


Excellent. Thanks for confirming that worked!