Everything functionality not working

I just installed the beta and am not able to get the Global Everything search to show any results. I was already a user of Everything so it was already installed (version 1.4.1).

Is there anything I need to do to enable the functionality?

Which method are you using to search via Everything?

Is it showing up as an option in the search field (top right of the lister, by default).

Yes, in the search field I clicked on the left dropdown menu and selected "Global Everything search". I then did a simple search (that works with Everything) and I get a "No search results were found." message.

Is Opus or Everything running with UAC elevation? If only one of them is, they may not be able to talk to each other.

(When checking Everything.exe in Task Manager > Details, there may be two of them. The one running as SYSTEM is elevated for me, while the one running under my own account is not elevated. It's the latter that's the important one.)

I don't have Everything running as Administrator but I am utilizing the service which I believe does. I do see two entries for Everything in the task manager and one is running as SYSTEM. I don't run Opus as Administrator but for a test I restarted Opus, running as Administrator.

Unfortunately it didn't seem to help, I still get no results.

Any other ideas or things for me to check?


I'm not sure what the best way to diagnose it is.

What kind of search are you trying? Does something really simple like dopus.exe return any results?

Are you using the standard installation path on C:? You also could try using the 1.5 alpha. At least it's working for me.

1.4.x is the version Opus is written for currently. Support for 1.5 will come later, once 1.5’s API is ready for other apps to start using.

Using Everything version 1.4.1. Installation paths for Opus and Everything are the defaults.

dopus.exe search works fine in Everything itself, Opus gives the 'no results' message.

I did reboot my computer and made sure all Opus processes were killed before running Opus as Administrator - no change, still not working.

Please don't kill Opus processes unless there's no other option, as it could corrupt your config if you kill it while something is being saved. Use File > Exit Directory Opus if you want it to shut down.

If Opus is running as Admin, please return it to normal, as Opus being elevated when the rest of the system isn't will cause problems.

Exit Everything completely and start everything.exe in DOpus. If that doesn't work, try:
Download the command line tool and check the output.
"D:\es.exe" -parent "D:\" -export-csv D:\test.txt

Yes, i read that a couple of times. But i am sure, that i'm using the latest 1.5 alpha, since i have no other version installed on my C: drive (i searched twice). I do have some 1.4s somewhere on my other drives, but i doubt, they are being used, since they are just installers, and the only ET exe is non operational, because it's not installed. I too find it confusing, but the + search as well as the filters i have work flawlessly.

Edit, i was over to my Admin account, no signs of an install other than 1.5 either. :thinking:

1 Like

Now i have confirmed, that i'm actually using 1.5.

I exited ET, went to C:\Programme, renamed two exes to

C:\Program Files\Everything 1.5a\SearchEverythingCoreCLI._exe
C:\Program Files\Everything 1.5a\Everything64._exe

then tried a + search in Opus. No results. Then renamed them back, started ET, same search term, and voila, it's back. Maybe someone with VMs cares to give it a try?

Searching with 1.5a also works here, the folder size doesn't work.

You could try

Set COLUMNSTOGGLE="scp:EverythingFolderSize/EverythingFolderSize(!,a,0)"

It shows the same sizes as Opus' folder size calculation.

The issue has been resolved. Based on WKen's comment above I downloaded the command line interface for Everything and did some testing with that but couldn't get it to work either.

I went to the Everything forum and was able to get the issue figured out with the help of them:

I had (in the past) installed the lite version of Everything and the lite version does not have IPC support. Once I installed the full version of Everything the command line interface utility started working and Opus 13 started working.

Thanks everyone for you help.

1 Like

I just installed the first beta but it seems that dopus cannot locate or integrate with Everything 1.5 that is installed on my computer. I don't even have the menu entry on the global search, only "windows search" (which is abysmall) or Dopus search.

Total Commander works fine with Everything so it's not everything's installation problem. I didn't find an option to force "DOPUS" to locate and use everything, while I do appreciates the automatic detection, there should be an option to force it when the dection doesn't works

Windows 11 23H2, DOPUS 13.0.36

I read the thread about a command line workaround but I don't like to use it, TCMD integrates with Everything without this extra step, I'd expect DOPUS to do it also, unless it works only with Everything 1.4 that is a no-no, at least for me.

Everything 1.4.x is the only supported version at present.

Everything 1.5 is still in alpha, and doesn't have a published API yet. We'll support it in the future, but not yet.

1 Like