GP SoftwareTwitter
Opus FAQsManualCommandsObjects

External Compare and Merge Tools 2.0

The merge buttons have a bug
ExternalCompare Product WinMerge Merge
Should be
ExternalCompare Product WinMerge Command Merge

As for WinmergeV2, if the command line args are the same it should work. If the command line arguments have changed check the Configuration of a new tool details in the first post.

@wowbagger receive the following when selecting EllieComputing:

image
Attempted holding shift and clicking button again, but same result.
Please advise.
Thanks!

the menu needs updating. Its missing the word Command, on the second line of the button. Also there is a bug where it's not showing the name of the exe correctly. Will update when at home.

If you update your button it should work.
From this

@icon:#ExternalCompare:EllieComputing,$glob:ExternalCompareMerge+EllieComputing
ExternalCompare Product EllieComputing Merge

Should be this

@icon:#ExternalCompare:EllieComputing,$glob:ExternalCompareMerge+EllieComputing
ExternalCompare Product EllieComputing Command Merge

Works, thanks!

I'm trying to install this, and I cannot get the button to show any icons. What am I doing wrong?

I've installed the script and it is enabled. I have then dragged the ExternalCompare.dcf file onto my toolbar after entering Customize Toolbar mode…

But I still get this:

I don't get it?

You can edit the individual buttons in the menu via Settings > Customize. They will be pointing to icons in exe files which aren't in the same place (or aren't anywhere, potentially) on your system.

Ahhh okay, thanks! Sorry, I thought that the icons were all supposed to be there, but greyed out if the paths weren't configured (as per this post External Compare and Merge Tools 2.0).

As always, well impressed with the speed with which you give help here Leo!

The icons are included in the ExternalCompare.osp, which also includes the script.
Assuming that package is installed and enabled then they should appear.

1 Like