Extreme CPU usage

Opus always was a bit slower and resource hungry than standard windows explorer (or similar programs).
So so good but it offers nice functionality to compensate for that.

But with U things got absurt.
Opus grabs 60-80% CPU on my P4-2.4 when idle!
When copying some files the usage goes op to 70-92%
Even when taking this vast amount of CPU power the result is extremely slow.
Deleting 10 files takes a minute.
UnRARing with Opus compared to standard window explorer is 20 times slower.
Copying files over my gbit LAN drops from 20MB/s to 200KB/s

Any idea what's causing this?
In case it makes a diffrence I have a legal Opus that automaticly suggests updates once in a while.


Is Windows-Explorer also slow in copy-operations? If so:

Sounds like the DMA-Mode of IDE-Ports are not activated and your harddrives run in slow PIO-Mode.

It could be related to this [url]Opus uses 100% CPU / problems with AVI files].

I've seen this 100% usage problem in the past, it's nothing to do with DMA - it's a rare bug that's not been traced to a definitive cause. The only thing to do is kill the process and re-launch Opus.

Windows explorer is fast. I even get 20MB/s over LAN.
The problems started yesterday when I upgraded Opus to the last version.
Besides all of that Opus also grabs lots of CPU when being idle.
In idle state there is (almost) none HD access.

I tried that but it has no effect.
I discovered something odd. Well odd in my understanding of things that is.
I used Opus in a normal way and started a program that uses the files that are shown in Opus.
I killed Opus with Tas Manager -> End Process Tree.
Not only Opus got killed but also the app that uses the files.
To me, not being a programmer, that looks like all file data flows frm HD through Opus to the other apps.
But shouldn't Opus just 'hand over' the file to the app and no longer interfere?

High CPU usage when idle is likely caused by the problems outlined in these two FAQs:

Sticky: Crash/exit/100%CPU when right-clicking certain files

Sticky: Crash/exit/100%CPU when viewing a certain directory

The only time I've seen CPU usage increase dramatically when copying is when I've had Virtual PC running on the same machine and I'm copying over a network. VPC seems to use a lot of CPU to work out if it should intercept the network packets or not. But if you're experiencing high CPU while idle, not just when copying, then my bet is it's one of the things in the above two FAQs.

I tried all the above suggestions. But I still have lots of problems.
Nothing in my PC changed after the upgrade.
Today things got extreme. It took me 2 hours to copy 1 big 4GB .iso file.
My HDs are fully defragmented and being WD Raptors they aren't of the slowest type either.
CPU usage stays at 97% for 2 hours.
As I said I just ran upgrade and that's it.
Is it possibly that the upgrade set some extremely power hungry settings?
I guess not because functionallity that makes a PC 100x slower and grabs 40x more CPU power isn't very functional :slight_smile:

Right now I'm doing some copying with some other things and everything goes very smooth. Dopus grabs about 6% CPU now....

Any idea's? Can I download a older version somewhere?

Does it only happen when copying certain types of file, or when copying very large files? I'd suspect something to do with an anti-virus program if that was the case.

These are long shots, but both of these which may also impact performance.

[Directory Opus loads real slow on Bootup)

[Filenames remain after moving)

If I take a look at a typical directory/copy operation I see a mix of:

  • huge 4.3 GB .iso .img files (movies)
  • Some operations involve copying the contents of a DVD with typically contains 4x1GB and about 20 files ranging from 1-300KB

I used NOD32 I even configured it not to monitor any of Opus processes.
Of course I could fully deinstall that but that's not a real solution because I don't feel safe without a virus scanner.
I didn't clash with Opus for over a year I happily used Opus.
And recently I monitored a processes in 'Task Manager' -> Processes.
To see what application grabs all that CPU power.
It was soley Opus that used that much CPU.
In the past I had NOD32 grabbing lots (but not extreme) CPU power like you suggested. But it's not the case now.
Well at least as I can track down the problem.

The weird thing is that during this mail I copied 10GB of files as described above. Absolutely no problems.

I just don't understand it. But I'm aware it's difficult for you to come up with a solution being 10 miles away :slight_smile:
So a big thanks to you and other trying to help.

[quote="kenalcock"]These are long shots, but both of these which may also impact performance.

[Directory Opus loads real slow on Bootup) [/quote]
Just being a copy A to B noob how do I flush collections?
I doubt having any.
And Opus starts up quickly. That contradics with the problem described in the article. But I going to try every suggestion that has even remote change of success.

[Filenames remain after moving)[/quote]
I don't think this applies to me but it gave me the idea of deinstalling everything I don't need 100%.

Not sure it's related but.
Two ago, before the upgrade, Opus reported I have a illegal version.
Or at least with a expired demo period or similar.
FYI I have a official version.
So I reentered my key 5 times. Everytime I was told the key was invalid or expired. Then I just rebooted and everything was OK.
Opus didn't even ask for my licence key that it was 'invalid' 5 minutes ago.
Probebly totally unrelated to my problem. But registry issues perhaps?

I have to go now.
I have a job to pay for the licence of Opus 9 :slight_smile:

Problems getting the licence key to stick have been caused by Zone Alarm in the past. Are you using that or anything similar? (NOD32 should be fine there, a bunch of us run it as well.)

I'm not sure how NOD32 works but it could cause other processes to slow down depending on how it hooks into them. To rule it out completely, you can temporarily disable the AMON part of it via its control panel (from the system tray), do a copy and see what happens, then turn it back on. No need to uninstall.

I've found NOD32 good in general but sometimes it causes problems. For example, it really slows down iTunes (as if it wasn't slow enough :slight_smile:) when compressing music since it keeps scanning the large temporary files that it makes every time they're changed. Configuring it to ignore the temp files solves the problem.

Anything which intercepts network traffic, like an active software firewall (Zone Alarm etc.) or Virtual PC/VMWare, is also a likely candidate for unexplained CPU usage while copying to network drives.

Zone Alarm at least seems to have a system where it identifies executables based on a checksum, so any time a program is updated you need to wait for Zone Alarm to update their list of checksums, assuming they know about the program, until which time ZA treats the program differently.

I've also seen slow-downs caused by anti-virus software on the destination network machine, but that's unlikely to cause high CPU usage on the local computer and so is probably not relevant here.