Feature request, abandon menu focus after a few seconds

Many times i find my shortcuts not working, because the main menu bar has the focus. Then i have to push Escape to cancel the waiting state of the toolbar.

Wouldn't it be possible to give Opus some time out option, like 3 or 5 seconds, where the focus is handed back to the lister automatically, to avoid this issue? I know, that i unintentionally cause this myself, but i happens all of the time. I wish, there was an option in "miscellaneous" to set a time out.


Edit: by the way, i see, why this happens so often. Whenever i switch back & forth in Dexpot between desktops, the state changes to have some menu item green lit in the main menu bar (the first one, in this case). So i'm causing the effect indirectly.

Does your Dexpot hotkey use the Alt key? You could change it to another modifier.

Yes it does. So that's why. I'll give it a try then. Thanks Jon!

Update. Actually, it still hapens all the time. Very irritating. So i'd like to renew my request for an option to turn it off completely.

I would like to add, it also happens after not having used Dexpot, for whatever reason. I suppose, it is because of the accelarator keys being activated, since i rarely use the mouse in Opus. So a general option "don't use accelerator keys in menues" would solve it.