Feature Transfer Error on install

Upon recommendation from a friend, I downloaded DOpusInstall.exe (v9.1.0.1 32 bit) from your website. When I go to install it stops after creating the GPSdirectory in my Program Files and gives me the handler:
Feature Transfer Error
Feature: Program Files
Component: Program Files
Error: Access is denied

The {556DF27F-5B74-11D5-B876-004005E12EF1} folder is created in C:\program files\InstallShield Installation Information. When I am forced to close the error message window, this folder is removed.

I have read through this forum and HAVE performed the following, but still get the error.

  1. I am logged in as the administrator
  2. All applications in the Install Shield Manager are Off (i.e. no automatic updates)
  3. Set the location to the root instead of c:\program files

I also tried copying the {556DF27F-5B74-11D5-B876-004005E12EF1} folder before it was automatically deleted. Then tried running the setup.exe from that folder, but that failed since it was looking for data2.cab.

I am at a loss at to what I should do to get this installed.

Computer information:
Thinkpad R60
XP Pro SP2
All virus scanning and adware programs not loaded.
Not connected to a network

Thank you in advance

I don't know if this will be the answer, but check that the installer was fully downloaded. It should be about 15MB in size and if you open the Properties for it it should have a tab saying it was signed by GPSoftware.

I say this since once or twice when downloading the installer my connection to the download server seems to have been dropped and Firefox still treated the file as if it was complete. It was quite confusing why it wouldn't install correctly until I realised I only had half the file downloaded and tried again. I didn't get the same error message but maybe the error message can be different if the download reached a different point.

If that doesn't help let us know and we'll think of something else. You might also want to get in touch with GPSoftware directly via their support page (linked in my signature) in case they don't see this message in the forums.

Thank you for your fast reply.
I did as you requested - redownloaded. Filesize: 15,619MB, version from properties page:
Same error

I also tried to submit a question to /Support.html however it was rejected because I am not a registered user - but I can't register because I can't install it!!

Any other suggestions?

If you try to create a new folder under Program Files, does that work okay?

If that does work okay then the best thing I can think of is to run Process Monitor while using the installer, then see if it flags up any obvious errors, or just attached the output log to a post here and I'll take a look at it.

I successfully created C:\program files\Directory Opus folder, but received same error when attempting to use that directory as the install directory. I then did a FileMonitor for the installation (attached as filemon.zip - it is a 3mb log file) - started just before I selected the directory to install the files to. I did see some failures and Not found statements, but don't know if they mean anything.

Again, thank you for your time.
Filemon.zip (170 KB)

What permissions do you have on the C:\Program Files, C:\Program Files\InstallShield, and C:\Program Files\Common Files\InstallShield\Professional?

I can't find any information about this specific error on the web but similar errors (like community.macrovision.com/archiv ... 31671.html) make it seem like a permissions problem triggered by a previous software installation (ie, not specifically related to Opus, but an Installshield-related issue).

Re: tech support - you can register for an evaluation code via the website without needing the software installed, and once you have done this you can use the support form.

When I right click on all these folders I don't see a Security tab. Only see a Sharing tab and nothing is checked. However, I log in with Administrative rights. Have never really logged in as Adminstrator, until yesterday when I tried to install Opus under that log in ID. I also received the same error. I even tried moving all the existing folders in C:\Program Files\InstallShield Installation Information. Any files in the ./professional or Installshield directory that I should look at renaming/removing?

I will also try the Support now that I know how to register. Thanks again.

You may have a corrupt user profile, so I suggest you create another administrative account, and log on with that new account and try the installation process again.

I presume you're using XP/Vista Home then?

How about you try renaming the actual folders themselves? Rename the C:\Program Files\InstallShield and C:\Program Files\Common Files\InstallShield both to something else (eg InstallShield_Old) and then try the install again. My theory is that something in these folders has the incorrect permissions set. If that works, the installer should create new folders automatically, and you could then shift the contents of the renamed folders back into the new ones (I think you would need to do this to avoid breaking the uninstall of any currently installed software.)

I tried renaming the 3 subdirectories in Program Files. Same error on attempted reinstall. It was interesting that none of the 3 subdirectories I renamed were recreated before I got the error message.
Also tried creating another admin user and installing. Same error.

I am running Windows XP Pro

Ah ok - in Pro, the Security tab won't be displayed if you have simple file sharing enabled. Turn this off through Explorer (Tools -> Folder Options -> View -> Advanced Settings)

According to this thread, and since from the filemon log you have an Access Denied error on [b]C:\Documents and Settings\All Users\Desktop[/b], then you should consider the solution in that thread or give permission to yourself on the Desktop folder under All Users folder.

PS: the culprit may not appear to be related to the error message, but many people solved their problem this way as it appears in that thread.

THAT was it!!! Getting access to Security and permissioning the AllUsers/Desktop for Administrator allowed the Opus icon to appear. No Users / User Groups were allowed access to the Desktop.

THANK YOU ALL for your wonderful, QUICK attention!!!!