GP SoftwareTwitter
Opus FAQsManualCommandsObjects

File Type Context Menu

I am running Win7x64 with Opus 10.0.1.0.4192.x64
I have used this guide in trying to setup a filetype context menu item:
[url]External Control Codes (guide)]
I have also read up in the Opus 9 online help for Control Codes here:
http://www.gpsoft.com.au/help/opus9/default.htm?turl=WordDocuments%2Fcommandcontrolcodes.htm
Finally I am aware of the tutorial here:
[url]Tip: Organise and Speed-Up Context Menus]

What is the problem with this setup below?

The expected context menu item does not appear:

The expected context menu item does appear if you hold shift key down.
In my interpretation this is the wrong way around

If I select 1 file and run the menu item in the Shift-RHS Click menu above I get this:

If I select 2 files and run the menu item in the Shift-RHS Click menu above I get this (below).
The {F} control code appears to have a consecutive action rather than the expected simultaneous action.
2 instances of the Application are spawned with identical error messages (as above)

Either turn off Preferences / Miscellaneous / Windows Integration / Hide Windows items on file context menus (shift overrides) or re-create the menu item and set its type to "Opus only".

Leo, thanks. It is clear I think that I have 2 problems
PROBLEM1 = Context Menu related
PROBLEM2 = Context Menu ACTION item not passing Fully qualified name properly

As you obviously worked out this setting was ticked:

I unticked it and tried again.

SUGGESTION 1 - Untick Hide Windows items on file context menus (shift overrides)
With Hide Windows items on file context menus (shift overrides) unticked now
I get this first up which was different and expected (below)

When I invoke UCompare4 I get the same error as before (8 below)
This is no surpise as we have not changed anything

When I invoke UCompare4 with 2 log files selected I get the same error as before (9 below)
That is the consecutive action instead of expected simultaneous action. Still no surpise:

SUGGESTION 2 - Recreate item and set its type to "Opus only"
Created as follows:

New items shows in context menu as expected:

UCompare5TypeOPUS now works prefectly. So SUGGESTION2 has fixed PROBLEM2 (Thanks)

Now I UNDO SUGGESTION1 i.e. I tick Hide Windows items on file context menus (shift overrides) again.
I RHS click a logfile and hey presto I have this:

The UCompare5TypeOPUS action still works perfectly and I no longer have to see all the mess. PROBLEM1 solved also.
Thanks twice over :slight_smile:

For future reference, when you have a context menu that's not Opus only, you can't use Opus-only codes like {F} - you would have to use %1 or %*, which are codes that both Opus and Explorer understand.