File types under Win 10

Hi folks..

What has MS done to file types in Win 10, made it a mess is what. Spoke to an emulator dev who actually programmes for a certain very well known company, and he said it's a shambles.

What I want to do and what I could do under Win 7 was to go to the 'open' part of a file type and add a command line argument which is needed by this emu (Hoxs64), now the arg '-autoload' worked fine in 7 but gets totally ignored in 10. I'm using the file types option in Opus to change it because the app / filetype program built in to 10 barely lets you do anything other than associate a filetype with the emulator.

The dev gave me a way to do it via the Registry but a: I want to avoid the registry and b: it requires quite a bit of work.

Is there a more simple way via Opus? I tried using quotes or no quotes with the command argument but no joy, it just ignores the arg and loads the "%1" file.

I can just use the emulator on it's own to load the file but I have always liked to automate stuff in Opus as an all in one tool.

Many thanks for looking


Do you want to launch the files from Opus and not mind what happens if they’re launched from outside of Opus, or do you need both ways to work?

Opus can definitely let you do this for itself, as it lets you override what happens for particular types within Opus.

It may also be able to do the change system-wide, but it depends how the file type is set up and can be more complicated.

Have a look at the type under Settings > File Types, and if you want something Opus-specific then change the Left Double-Click event. “%1” will work to insert the file path into the command as you’re used to.

I'm happy for it to just launch from inside Opus.

I went to the file type under settings and then the 'event's' tab and adjusted the left double click box but nothing is working.

I just want it to run this

E:\Commodore 64\hoxs64 -autoload and the %1 for the chosen file. I'm not very experienced with the parameters available there.


Sorry Leo, I made a pigs ear of this, I can configure a button to do it perfectly, it's the double click of the file that won't allow the argument to be ran, it runs the emulator but without the -autoload it won't run the file. This is purely from double clicking the file in Opus (or wherever), as said the created button does it right but it would be nice for the standard double click to work properly as well..

Sorry for my daft explanation previously, it's been driving me nuts for a couple of days, I can live with Opus doing the work via button but would be nice that it all worked as normal..

If you have a working button, the exact same command should work in the double-click event.

I'd expect it to be something like:

"E:\Commodore 64\hoxs64.exe" -autoload "%1"

Or, since it's an Opus-only thing, you can use the more explicit {...} codes instead of %1:

"E:\Commodore 64\hoxs64.exe" -autoload {filepath$}

Make sure the quotes around the exe path are included, since it has a space in it.

All good now, thank you very much Leo, as always..

1 Like