GP SoftwareTwitter
Opus FAQsManualCommandsObjects

FileShredder context menu missing (not just in Opus)


#1

Hi,

Another context menu problem.

FileShredder menu is appearing in Explorer but not DO.

Holding SHIFT doesn't help.

I'm using DOlite on W10.


#2

Any insight from devs?

Cheers


#3

Secure Delete is built into Opus if you need it. By default it is in the menu attached to the Delete button on the 2nd toolbar row.


#4

On DOlite?

File shredder has a delete later option that I tend to use quite often.

Why isn't it appearing in DOlite?


#5

Apologies, the built-in secure delete is only for pro.

File Shredder seems to work fine with Opus here:

Is your Opus install up to date? If it is already, try reinstalling File Shredder, or using its option to turn off the right-click menu, then turn it back on so that it resets the relevant registry values.


#6

Surprising as it's a brand new system and I've just installed both DOlite and File Shredder.

DOlite v12.6 reports that it's up to date.

Uninstalled File Shredder and eliminated all remaining flies, reinstall or changing the integration options does not have an effect.


#7

If you open Notepad.exe, then use File > Open and right-click a file in there, does the menu appear there?


#8

No, it's not there.


#9

That means either File Shredder is only adding the menu items within Explorer.exe for some reason (some programs choose to do this by default; some have it as an option; most don't do it at all), or antivirus or something is blocking the extension from being loaded into other programs.

Since it affects Notepad, you know it's not related to Opus itself. Asking the File Shredder authors may get a better answer.

I'd also check that File Shredder is on the latest version, in case that's why it showed up for me but isn't for you.


#10

Hmmm, good to know.

File Shredder is up to date.

It showed up in your DO pro or lite?


#11

I only tried Pro but there shouldn't be any difference between Pro and Light here, and if it's not showing up in Notepad for you either then you know the problem isn't with Opus.


#12

There's no tweak you've made to your system to show context menu items explicitly added to explorer.exe?

I've just tried the File Shredder via notepad test on two more machines - doesn't appear on either.


#13

No. I tested in a virtual machine that has had almost nothing done to it other than installing Opus.

You need to talk to the File Shredder authors rather than us. Only they can tell you how their extension works and where its menus should appear and why.


#14

Interesting nonetheless.

Thank you for the assistance :slight_smile:


#15

I'm now evaluating Pro and unfortunately this is still an issue. I just tested it on a newly built VM myselt and File Shredder is not in the context menu there either. There must be something different in your installation procedure or settings.

Work requires me to use File Shredder specifically.

Naturally, the Notepad test shows the same result as before - not shown in the context menu.


#16

If it's not appearing in Notepad either then it's something File Shredder is doing, whether intentionally or accidentally, so that it is only adding its menu if the process is explorer.exe on your machine.

You need to talk to the File Shredder authors rather than us. Only they can tell you how their extension works and where its menus should appear and why.

Having said that, if File Shredder has a command line interface then you could create a context menu item, toolbar button or hotkey in Opus which will run it against the selected files as a replacement for its normal menu.


#17

Why was it working for you then?


#18

I have no idea. You need to ask the people who make it why it isn't working for you in Notepad and Opus.