Filter Bar doesn't clear the search on Escape

I have the Filter Bar set as the default mode for FAYT.

If the option Always, or Whenever a filter is set are used for when to display the Filter Bar, one must hit Esc twice to close it (after reading the link below, I understand that this is expected). For example, if you type "file", hitting escape will delete all characters but "f". A second press of Esc will close the bar. Why the bar isn't cleared, I don't know.

If the option Only when editing the filter is chosen instead, the Filter Bar always closes on first press of Esc, which may or may not be intentional. Also in this mode, pressing * when the Filter Bar is closed, will open the bar and filter by *, without displaying * in the field.

It appears the first issue was already discussed some time ago, and perhaps a fix was never issued?


Edit: In fact, the asterisks not showing issue may be a bigger one and related to something else I was experiencing: sometimes the Filter Bar just doesn't open, but it is filtering (as indicated by hidden items in red appearing in the status bar). After a few more characters, it shows, and sometimes only with the last few characters typed. Other times, the Filter Bar shows up on first character, so I'm not sure what's going on.

- Directory Opus v12.23.3 Beta x64 Build 7752
- Windows 10 v20H2 OS Build 19042.906

If the filter bar's text field has the input focus, pushing Esc cancels any edits done to it and restores it to how it was before it got focus, and gives focus to the file display. If the filter is now empty then it'll also now be hidden (unless set to always be shown).

If the file display has focus, and a non-empty filter is in effect, then pushing Esc clears the filter.

If it's working that way then it's working as designed and there's nothing to fix.

That doesn't seem to happen here. If I type * to open the filter bar, then type file, then Esc, it'll clear the filter, rather than leave it set to f.

Maybe if you don't use a key to open the filter bar, and have it open when typing, it'll reset to the first character that was typed. Just hit Esc again in that case, if you want to clear it.

If the filter bar is empty then it will show everything, the same as if the filter was set to just *. I'm not sure what else you'd expect in that situation.

The filter bar isn't the only thing which can cause files to be hidden.

If I understood the person in the linked topic, the issue is the same: I have not performed a search, I type "file", it automatically filters after a short pause, I press Esc, and all that is left is "f". I did not originally search for "f", or slowly type "f" so that it automatically filtered before typing the rest of the word. It should be clearing fully, giving focus to the File Display, and then hiding, according to how you say it should work, right?

Which Display Filter Bar option do you have set? This only happens when using Always or Whenever a filter is set, not Only when editing the filter.

I didn't expressly say that it wasn't showing everything, however in that very case, * did hide items because the Filter Bar is set to regular expression mode, not wildcard mode. I was trying to amend this point about the asterisk in my edit to say that it appears related to sometimes typing and the Filter Bar not showing at all until a few characters in, despite the filtering actually occurring.

I realise this, however it's only when I begin typing that the red hidden items count appears. It's related to performing the filter.

I recorded a video that should hopefully clear things up:

Was this able to be reproduced?

It's in a queue to be looked at in more detail. We'll update the thread if we need more info etc.

1 Like

I was a bit disappointed to see that no attention had been given to this for the recent beta. I would have thought this would have been higher on the list of things to fix judging by how broken it currently is, but it could be that the fix is more complex than I imagine.

In any case, for reference, this is one of the configurations that exhibits many of the issues:

Filter Bar Settings

Issues such as:

  1. The Filter Bar simply will not appear when typing any string that doesn't contain two of the same character consecutively.
    • E.g. Typing "FOLDER" will cause the filter to first filter by "F", then "O" (not "FO"), then "L" (not "FOL"), etc.
    • E.g. Typing "HELLO" will have the same behaviour up until typing the second "L", which is when the Filter Bar appears and starts filtering correctly, i.e. the rest of the word is what is used to filter: "LO" (obviously, the word in its entirety should be what is actually being filtered upon).
  2. Hitting Esc clears everything from the text field, except the first character (likely related to issue 1 above).
    • In the case of the "HELLO" example, only the second "L" would remain since this is the first character of the "LO" string that is being filtered upon.
      • Changing the "Display Filter Bar:" option to "Whenever a filter is set" will have a slightly different behaviour: typing "HELLO" will now appear in full in the filter field (not just "LO" as before), but pressing Escape will clear everything but the "H" in this case, since "H" is now the first character of the string filtered upon.
    • This means the filter is still filtering by 1 character (as evidenced by a high count of hidden items shown in the Status Bar). Pressing Escape a second time fully clears the filter (so "L" is not being filtered upon) and the hidden items count in the status bar disappears / becomes the expected value for when the filter is inactive.

These issues are most easily observed in a folder containing hundreds of items (in my test case, hundreds of folders). The two points above are more accurate descriptions of what I had written in my previous posts.

And some possibly helpful observations:

  1. Pressing Enter after filtering means that only one press of Escape is needed to clear and deactivate the filter: no more leftover character from the filter string (which should obviously be the case even when pressing Escape without having pressed Enter beforehand).
    • Pressing Enter when the "Display Filter Bar:" option is set to "Only when editing the filter" leaves no indication that filtering is still active since pressing Enter not only causes the focus to move to the File Display, but also causes the Filter Bar to close/hide. Only if you are paying close attention to the number of hidden items would you possibly realise that the filter is still in effect. Maybe something can be done about this? Such as the Status Bar definition showing e.g. "0 / 1,234 (Filtered)" when the filter is active.


System information:

- Directory Opus v12.24.1 Beta x64 Build 7860
- Windows 10 v21H2 OS Build 19043.1083

It's still on the list, but it's something that only happens with particular, non-default settings, and is easy to work around and only an issue for one person so far, so other issues got priority for this beta.

We've implemented lots of your suggestions so I hope you don't feel like we're ignoring you.

It is true that it's possible to work around some of the issues by using a "Display Filter Bar:" option other than "Only when editing the filter" and have the filter work functionally (and I have now done so), but even with default "Reset Page To Defaults" used for the "FAYT and Filter Bar Options" preferences section, the single character issue after pressing Escape remains, and this has been a problem since 2012. Due to the remaining character bug being minor in this configuration, it's something I can live with.

On further investigation, all of the mentioned Filter Bar issues in posts above only seem to manifest when "Filter Bar" has been set as the "Default mode (no activation key required)", instead of the factory default of "Find".

The solution I've settled upon: do not set the Filter Bar as the default mode, and instead press * (Filter Bar Activation) each time you wish to filter more powerfully than what the Find bar can provide. This makes it a bug-free experience as far as I can tell at the minor inconvenience of having to start the Filter Bar before each time I type. Alternatively, just choose the least buggy option as stated in the first paragraph of this post, and keep the default mode as "Filter Bar".


We've fixed this for the next beta.

1 Like