Filter grp:Archives shows files ending in .rar.jpg

I was expecting the quickfilter group "Archives" to only show archives, but it also shows files that have the following ending: .rar.jpg, which are image files. I double-checked to make sure the ending .jpg is not part of my archives file group.

EDIT: To reproduce:

  • Create a folder with just two files, one ending in ".rar" and one ending in ".rar.jpg"
  • Open the quick filter bar, use dropdown menu - select Archives (1), and both files are shown.
  • Change the file ending from .rar.jpg to .jpg, and only one file is shown
  • Note the drop down correctly shows the number of Archives as (1) in the selection, but nevertheless two files are displayed after clicking on the selection.

We'll change things in the next beta so that using a grp:xyz wildcard automatically disables the "partial matching" option.