Filtering in virtual folders

Comma filtering in the FAYT mode works fine in normal folders. However, when i use it in the Desktop folder, there is a lot of folders also being listed. For example, i hat three RAR files on the desktop, but the comma type FAYT also listed lots of folders, not being related to the search term. Is there maybe a better search mode for virtual folders?

What is comma filtering?

Maybe a screenshot would help show what you're doing and seeing.


I could't find a better description for this function. Because writing ","-filter looks strange.

Makes sense. I think mine has a different hotkey.

What are you typing as the filter / pattern?

In that case, it was just ,rar. And it did find the files, only there were lots of folders with no relation. Maybe following setting in preferences -> folder isn't ideal? Can't test it now, because it's on another machine. The setting is "treat all virtual folders as real ones".


Can we see a screenshot of the folder with the filter applied and also visible?

Sure. Note, that i simulated it on my machine, while the original case was on another. But i have the same effect here. The upper image shows the state before filtering.

It looks like you're using Flat View? Is the question really about filtering folders in Flat View, rather than filtering in virtual folders?

There's an option on the filter bar, bottom-right of your second screenshot, to apply the filter to folders when in Flat View. But not that if a folder is filtered out, all of the things inside it are as well.

Yes, it looks like flatview, but the status bar mode info says i'm in Details mode, as seen in the screenshot. Also, i didn't deliberately apply the flat mode in that case.

Edit: and yes, i have tried the checkboxes, if it makes a difference, which wasn't the case. But i have found something strange here. When i use my button to change over to
Set FLATVIEW=On,Grouped,Toggle

the status bar info still says "Details", although the apperance changes to the grouped flatview. I will post my status bar code, so you could look into it, if there is something wrong.

Flat View can be on at the same time as Details Mode.

Something must be turning it on, as it won't turn on by itself.

Well, i looked into the folder options, but no hint about any possible flatview setting. Looks you are right about the mode. But i can't figure out, why the desktop folder is in flatview mode when i enter it. I'm using the slash command to go to that folder. :thinking:


Now i made a button

Go /desktop

But i still will get the flatview. Seems like somethings is broken in some of the ini files?

This is weird. When i go into the Desktop, i have the flatview. Then, after using
Set FLATVIEW=On,Grouped,Toggle
it toggles the flat view back to normal, and i can do the search like intended. But if i put the same commands into a button

Set FLATVIEW=On,Grouped,Toggle
Go /desktop

it won't work anymore, even though it's technically the same thing.

Maybe you've installed a script that turns on flat view automatically for some folders.

Flat View normally has to be turned on explicitly. It's not something that happens at all out-of-the-box unless you flick the Flat View button, so it has to be happening due to something you've installed or reconfigured.

Layouts, Styles and Tab Groups can also turn on flat view, if you're using them to navigate to the folder. But if it's going from off to on when you change folders via any normal method (and you haven't edited the toolbar button you're clicking on to do that) then I would suspect a script.

Sounds like you installed it in 2015:


Jon, you found it. Indeed, there was a long forgotten script with that function. That's why it was so stubborn, overriding the Set flatview=off command. Thank you and Leo!