I'm using a Button which searches in C: and D: without opening the find panel since DOpus 9. The Code of this Button is:

Find in C: D: NAME {dlgstring|Suchbegriff:} QUIET SHOWRESULTS=tab COLLNAME=Suchergebnisse 

Now I wanted to edit this Button to do the Search in the active directory by replacing "C: D:" with "{s}" and found this doesn't work because the QUIET-Argument is ignored and the panel appears.
"Find in /mycomputer" or "Find in {alias|mycomputer}" also doesn't work because simply nothing happens.
After resetting the Button to "Find in C: D:" the search is not as quiet as before. I'm now getting a small progress Window.
In the Button Editor I couldn't find the QUIET Argument although it still seems to (partly) work with Drives.
Is QUIET no longer supported? I'd like to have it working without showing any Windows.
Shouldn't the Find-command understand the Pathes and Aliasses of DOpus?
What I really would like to have is a Quicksearch-field which does "Find in {s}"
The existing Quicksearch doesn't work good for me because I disabled indexing on all drives. So it's very slow and doesn't really find everything. It finds a lot of things not really related to my search because it begins the search before I ended up typing. "Find as you type" is a mess for a slow typer like me if it's not updating the results with every letter I add to the field.

The QUIET argument isn't needed anymore (I think it'll be ignored if you pass it, to avoid breaking old buttons).

I suspect the problem is what you're typing into the dlgstring box.

e.g. You haven't quoted the {dlgstring|...} so if what you type contains any spaces it will turn into multiple arguments.

Deleting the QUIET-Argument really doesn't change the behaviour of the Button and I can live with the little Progress-Window. But if I try the following it's unfortunately not working without opening the Find Panel, no matter where I placed some quotes:

Find in "{s}" NAME "{dlgstring|Suchbegriff:|}" SHOWRESULTS=tab COLLNAME=Suchergebnisse   

...and this one opens "Suchergebnisse" but doesn't find anything:

Find in "/mycomputer" NAME "{dlgstring|Suchbegriff:|{clip}}" SHOWRESULTS=tab COLLNAME=Suchergebnisse   

I tried another custom alias pointing to a real path and it worked fine. I tried "/defaultright" (which is "Computer" for me) and it didn't work. So the alias-problem may be related to virtual directories.

"Find in {s}" is also working on other directories than "Computer"

Find in Computer won't work. It isn't a real directory.

I expected it to work because the Quicksearch can do it. So I always tested with "Computer" in the active Lister at first.
Sorry for waisting your time with this and many thanks for your unfailing assistance.

I'm now quite happy with a 3-Button with left: "Find in {s}..." right: "Set UTILITY=Find,Toggle" to show the panel and middle: "Find in (List of all possibly occuring driveletters)..." to emulate "Find in Computer". Empty and currently not available drives are skipped without throwing an error with this one so it's working fine. Another benefit is that I can skip e.g. the DVD-drive from the list.
After some searching and trying I also found the "CLEAR"-Argument to clear recent search results which makes the Button perfectly working how I want it to do.

It's my fault for not reading your original question properly. :slight_smile: You mentioned you were searching in Computer but I didn't notice that detail at first.