.flac files not playing

I am a new user who uses Directory Opus for home use, it satisfies the most OCD afflicted amongst us, and I continue to be impressed (overwhelmed) by the depth of the program and the changes you can make, but onto my issue.

When I first installed the trial Pro version, and would click on a .flac file it would go to trying to endlessly load the file without success. When I then tried to click on closing the operation, or the Viewer Pane, the program would freeze requiring a force close. After reading some of the posts here I've managed to change the behavior to no longer freezes, but just displays the files thumbnail as .flac (Shell Thumbnail) in the Viewer Pane. To get to this point I uninstalled the K-lite codec pack, and a couple of unused music players. Mp3's play correctly in Windows Media Player, and I can double click the .flac file and it will open and play in my default music player foobar2000 correctly.

This isn't a deal breaker for me obviously or I wouldn't have purchased the program, but it would be nice to have it work as it is supposed to (to my understanding), using Audio Tags to play the .flac file.

I have tried:

  1. Resetting the .flac default player in Windows to WMP.
  2. Add .flac to the config file for both the Generic ActiveX 32-bit and 64-bit plugins.
  3. Add .flac to the Movie Plugin to see if VLC might play the file.
  4. Changing the Priority order of the Plugins.

If my understanding in reading some of the posts is correct then it appears that some program(s) or shell extension(s) may be interfering with Dopus from playing the file. Any input on how to determine what might be the offender is greatly appreciated.

Thanks for reading this,

My config looks like this and the preview pane plays .flac without a hiccup. Setup should be fairly standard, although I might have forgotten things over the years. No extra codec packs etc. installed on my system.

Thank you for your reply. I aped your setup and it now shows the player with filename.flac (Windows Media Player), but doesn't play. The Metadata displays correctly. I'm making the assumption here, possibly incorrectly that the .flac file should play, like mp3's do when you click on them once, or does it just display the metadata panel?

Windows Media Player doesn't natively support .flac, so without adding a codec for that I don't know how it would play the file. I can get to this point but no further, either a WMP window that doesn't play or a thumbnail from filename.flac (Shell Thumbnail) in the view pane.


You probably need to install a FLAC codec for Windows Media Player to use for the viewer pane to play FLAC files.

Check that WMP itself can play them first.

Thanks Leo, that is what I did and it took care of my problem.

Thanks to all,