Folder Format Collections in Tab Groups

That will happen if you save a new style with multiple tabs. It creates a tab group for the style, and flags the group as hidden so it doesn't clutter up your tab group lists.

If you go to Preferences / Folder Tabs / Tab Groups, you can view and edit hidden groups there. Maybe it has some format details still turned on.

Which aspect of the format is being overridden from what you want?

If you go to Preferences / Folder Tabs / Tab Groups, you can view and edit hidden groups there. Maybe it has some format details still turned on.

I've tried unchecking any format details (Columns and Grouping / View / Sorting Options) in the Tab Group format options for that folder. I've manually set the Style to load with that Tab Group (I've also unchecked any format details in the new "styletabs.TabGroup" it created just in case, too).

When I load the Style, the format is still not what I've set the Path Format to be, and the padlock says the format comes from the Tab Group. If I back out to a parent folder and then back in to the same folder, it loads the correct format and the padlock says it now comes from the Path Format.

Additionally, if I load the Style and then right click that folder's pad lock and press "Reset to folder's format", it will load the correct format. :face_with_raised_eyebrow:

Am I going about this wrong? I just want a Style that loads a predetermined group of folders, with a toolbar, and I want the folder formats to be consistent with whatever formats I set in the Folder Formats preferences (Path formats, etc).

Which aspect of the format is being overridden from what you want?

Anything really. Sorting options, display options (lists, thumbnails, etc), it's always being overridden by the Tab Group format even though I've disabled everything in there.

Also, weirdly enough I just noticed the exact opposite happens with a different folder...

When I load another Style (with its own Tab Groups), the folder for some reason does load the correct format (padlock says Default Format + Path Format :+1: ) BUT it technically should be looking at its Tab Group formats which are enabled and custom. :face_with_raised_eyebrow: I've added grouping, different display and sorting for the experiment, none of which are showing.

I am so confused.

How are you loading the first style? I.e which command/menu item is being run.

I made buttons to change the styles. The first one I was talking about is a button with:

Prefs STYLE="Stream Time"

and the other buttons are also the same, just referencing different Styles.

NOTE: This isn't to say that one style is working the exact opposite from the other. It just seems random.. some folders are getting their format from the "Tab Group" (even if I manually uncheck any format options for that Tab Group's folder), and some folders are getting their format from the "Path Format", even if I manually DO enable format options for that Tab Group's folder (for the experiment).

What happens if you load the tab group directly without going via the Style? E.g. with Go TABGROUPLOAD="#styletabs.TabGroup" ?

Hmm doing it that way loads the folders with the correct formats :+1: Am I doing something wrong with my Styles?

From trying some things out today, it looks like there is a bug where the format within the Folder Tab Group gets applied when you load the Style, even when the format's pages are all turned off.

We'll get that fixed.

1 Like

Awesome, thank you in advance!
Let me know if there's anything I can do (or test) to help.

This should be fixed in the next beta. Please give it a try when it's released (probably in the next week or so), and let us know if you still have problems.

1 Like