GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Folder jumps from active folder to desktop

Preferences / Launching Opus / Explorer Replacement / Don't replace Explorer

OPUS is set to: Don't replace Explorer

I tried dragging the same URL from Firefox into the same folder as before, but within Windows Explorer, and did NOT have the problem of Windows Explorer jumping from the active folder to the Desktop. So, it seems to be something to do with Opus.

The first thing I'd do is try downloading the latest version, in case that fixes either problem by itself.

We're about to release 12.14 in the next few hours, so you might want to wait for that, then download it via the post that will appear in the New Releases area here at the forum.

Hi Leo, I did install v12.13 but still have the issue

When you run the update checker, does the lister lose focus (e.g. titlebar close button changes from red to white)?

Do you have anything installed that changes the look & feel or behavior of windows? Or anything that automates e.g. closing windows or responding to prompts or similar?

the lister does NOT lose focus.

To my knowledge, I have nothing installed (e.g., "Fences") that changes the look & Feel. And nothing that automates responses or replies to prompts.

After clicking Help > Check For Program Updates, please create a manually generated process dump and send it to us.

We might be able to see from that where thing are getting stuck.

OK, I just sent an email from Dropbox with the share link to the dump file.
Thanks,
Ben

We haven't received any email so far. Was it sent as an actual email, or to a dropbox account (which won't exist if so)?

If it's sent as an email, please check the address it was sent to, which should be crashdumps@gpsoft.com.au

Hi Leo,
I just resent the link. Apparently, there was a problem when I tried sending the link from within Dropbox.

Thanks,
ben

did you get the dump file?

Received, thank you!

Please download and unzip this, then run it via Command Prompt:

ConsoleApplication1.zip (57.8 KB)

This only works with English versions of Opus. It's a quick tool that should find the Opus News window and force it to be visible. That may then reveal what is going on with the updater.

If you run it via a Command Prompt, it should either tell you it can't find the window (as in the first example below), or report some information about it and then make the window appear (as in the second example, in the same screenshot):

Please try that and let us know what happens.

this is what I got when I ran the program:

Found Opus News window: 00281146
Process ID: 10304
Window moved.

Is something blocking Opus from accessing the internet? That looks like what's breaking update checks at least. Check firewall and similar software.

after running ConsoleApplication1, when I selected to check for updates, I got the dialog box that i just posted. I rebooted my PC and went into windows 10 Home Firewall and added DOPUS to the list of apps that can communicate through the firewall. Now I get nothing, again, when I click check for updates: no dialog box and no error message. It's like I never selected check for update

You may need to keep running the exe to force the dialog to appear between tests, until whatever is blocking Opus accessing the internet (or DNS, at least) is working again.

In the next update we have a fix coming for that issue, where if the update check is triggered automatically (due to not being run in a while) and then gets stuck, you're then unable to make the dialog appear. The exe I posted works around that issue for now, and the underlying problem is that something is preventing Opus (dopus.exe) from accessing the internet.

Presumably the FTP functionality in Opus is also not working, if you try with a public FTP site (e.g. ftp.demon.nl).

Make sure nothing is turned on in Preferences / Internet / Proxy as well, unless you need to use a proxy.

After making changes to firewall/security/network configuration, I'd recommmend fully exiting Opus (via File / Exit Directory Opus) before testing again.

the proxy was the problem. I did not know that DOPUS had its own proxy setting so I never thought to look at it. but is somehow had some garbage proxy setting. When I cleared that out, the update checker now works

I think that's that problem solved.

On to the Firefox issue:


I can't repro the problem, but I think I can guess the trigger.

When you drag a URL into a folder from Firefox, Firefox sometime tells the entire OS to refresh all the filetype icons, which in turn causes us to rebuild the ffolder tree. That's probably what is causing the folder change.

You can see all the icons on the desktop flicker at the same time this happens.

There's no reason for FF to be doing this, but I'm also not sure why it should cause a folder change/navigation in some situations. Maybe if the tree takes too long to refresh we end up deciding the current folder no longer exists, or a selection event gets triggered.

I'll see if we can make it so only the icons are refreshed rather than the whole tree being rebuilt.

thanks Leo. I appreciate your investigating this.