GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Folder jumps from active folder to desktop

#1

After dragging a url from firefox into DOPUS folder, OPUS jumps from the active folder to the desktop. How do i fix this?

Also, when I try to have OPUS check for updates (within the Help Menu), NOTHING happens. I now find that I am 5 versions BEHIND.

OPUS v12.7 x64
Windows10 Home X64

Thanks,
Ben

#2

After dragging a url from firefox into DOPUS folder, OPUS jumps from the active folder to the desktop. How do i fix this?

It sounds like Firefox is opening the desktop folder in a new window. If you turn off Explorer Replacement do you get an Explorer window opening instead?

Also, when I try to have OPUS check for updates (within the Help Menu), NOTHING happens

Do you mean literally nothing? No window comes up at all?

If you go to Settings / Customise and then right-click on the Check for Updates command in the Help menu and choose Edit, what command is it set to run?

#3

Hi Jon,

Thanks for your quick reply.

Drag into OPUS - I may not understand what you're saying about opening in a new window, but from what I can tell, OPUS jumps from the directory I just dragged the URL into to the Dekstop - no new windows are evident. How do I turn off Explorer Replacement?

Re: Updates: correct no window opens, no web page opens, NOTHING happens
editing the Help | Update menu shows this
Help CHECKUPDATE

thanks again,
Ben

#4

image

#5

Preferences / Launching Opus / Explorer Replacement / Don't replace Explorer

#6

OPUS is set to: Don't replace Explorer

#7

I tried dragging the same URL from Firefox into the same folder as before, but within Windows Explorer, and did NOT have the problem of Windows Explorer jumping from the active folder to the Desktop. So, it seems to be something to do with Opus.

#8

The first thing I'd do is try downloading the latest version, in case that fixes either problem by itself.

We're about to release 12.14 in the next few hours, so you might want to wait for that, then download it via the post that will appear in the New Releases area here at the forum.

#9

Hi Leo, I did install v12.13 but still have the issue

#10

When you run the update checker, does the lister lose focus (e.g. titlebar close button changes from red to white)?

Do you have anything installed that changes the look & feel or behavior of windows? Or anything that automates e.g. closing windows or responding to prompts or similar?

#11

the lister does NOT lose focus.

To my knowledge, I have nothing installed (e.g., "Fences") that changes the look & Feel. And nothing that automates responses or replies to prompts.

#12

After clicking Help > Check For Program Updates, please create a manually generated process dump and send it to us.

We might be able to see from that where thing are getting stuck.

#13

OK, I just sent an email from Dropbox with the share link to the dump file.
Thanks,
Ben

#14

We haven't received any email so far. Was it sent as an actual email, or to a dropbox account (which won't exist if so)?

If it's sent as an email, please check the address it was sent to, which should be crashdumps@gpsoft.com.au

#15

Hi Leo,
I just resent the link. Apparently, there was a problem when I tried sending the link from within Dropbox.

Thanks,
ben

#16

did you get the dump file?

#18

Received, thank you!

Please download and unzip this, then run it via Command Prompt:

ConsoleApplication1.zip (57.8 KB)

This only works with English versions of Opus. It's a quick tool that should find the Opus News window and force it to be visible. That may then reveal what is going on with the updater.

If you run it via a Command Prompt, it should either tell you it can't find the window (as in the first example below), or report some information about it and then make the window appear (as in the second example, in the same screenshot):

Please try that and let us know what happens.

#19

this is what I got when I ran the program:

Found Opus News window: 00281146
Process ID: 10304
Window moved.

#20

Is something blocking Opus from accessing the internet? That looks like what's breaking update checks at least. Check firewall and similar software.

#21

after running ConsoleApplication1, when I selected to check for updates, I got the dialog box that i just posted. I rebooted my PC and went into windows 10 Home Firewall and added DOPUS to the list of apps that can communicate through the firewall. Now I get nothing, again, when I click check for updates: no dialog box and no error message. It's like I never selected check for update