Folder Size for Windows makes DOpus freeze


Just so you know - when using Folder Size for Windows (, Directory Opus freezes each time you start it up in any folder where Folder Size would be active. It does not freeze when you open up My Computer first for instance. It also doesn't freeze when you start there and then navigate to other folders.

It would be nice if this could be fixed, so that I could either choose to use Folder Size in DOpus (I know DOpus can do something similar) or, more importantly, use Folder Size in Windows Explorer.

Thanks! (or should I submit this elsewhere? :stuck_out_tongue:)

It's worth reporting things like this to GPSoft directly:

Thanks for the link, will support it there :slight_smile:

err.. submit. Interesting that it's not possible to edit posts here.

It's intentional.

Too many people were editing their initial posts after getting questions answered, either removing the question or asking a new one. This makes the forums less useful for everyone.

People just need to be a little more careful before hitting submit. :slight_smile:

Haha, I'll try to hit "preview" before submitting each time :stuck_out_tongue: Thanks for the explanation.

I've tried this in both XP and Vista and it seems to work fine in Opus, can't get it to freeze/lock up at all. Any other clues?

That's odd.. I installed and reinstalled the program several times to check if it was the problem, and every time I had it installed, DOpus froze when I loaded it with a shortcut like this: "%SystemRoot%\explorer.exe /e,D:\My Downloads". Never any problems when I had it uninstalled..

I'll try to do some more tests, but it definitely has to be this program since I didn't change anything else on my system. I understand that it's important for you to be able to reproduce it..

So it only freezes when you launch it in that manner? What about if you just run Opus from the desktop icon and browse in a Lister normally?

And at what point do you get the freeze?

I just re-read your original message again - sorry, I didn't understand initially that this only occurred when you launched Opus as you describe. But I just tried that as well and still did not get any lock-up.

It always freezes when I launch DOpus and the folder being automatically opened in the Lister has the Folder Size column active. In other words: it doesn't freeze when opening My Computer since there is never a Folder Size column active there. From My Computer I can then browse to a folder with a Folder Size column active without any problems.

What I'd like to test later today is if I can have the program installed next to DOpus (just not use it there) if I remove all references to it in any column setup in DOpus. That would be good enough, even though it seems as if Folder Size is a little better optimized than DOpus' solution. I will also try and see if there is another way to make this reproducable.

It freezes immediately on starting up a new Lister. It shows the DOpus interface, but doesn't load the path, the folder tree or the file listing.

Weird. I tried exactly that (actually I added the 'Folder Size' column to the Custom folder format so that all folders would get it) and it still works fine. This is under XP - what version of Windows are you using?

Weird indeed. In my testing I'll try to follow your steps (just add it to the Custom folder format first).

I'm using Windows XP Pro, SP2 (+ all updates), English version.

I wonder - does it only do it on a specific directory? In your example you use D:\My Downloads - is this in fact the only directory it does it on? Maybe there's something about that directory (some folder that is inaccessible or something) that is causing it?

Nope, it was doing it on other directories too. For example, when I was in my photos directory and closed DOpus, then started it again using the last Lister, it froze on the photos directory.

Okay, I installed Folder Size again without activating its column(s) in DOpus. Everything seemed to work fine. I could open DOpus with the shortcut fine - but then I remembered something: DOpus froze only when it was not running and I was using the shortcut.

So, I closed down DOpus completely (not in systray or anywhere) and started a Lister in a directory where normally Folder Size would be visible in Windows Explorer. Boom! Freeze.

Then I End Task-ed DOpus, started DOpus from My Computer and everything worked fine again. The aforementioned shortcut too.

It seems as if it only goes wrong when DOpus is not already running and you open a folder on a cold start where Folder Size would be running in Windows Explorer. Can you reproduce this now?

I'll also try to contact the author of Folder Size.

Nope, I've tried that already (your explorer.exe /e,blah blah blah etc). Works fine here :slight_smile:

Yes, that works fine here too if DOpus is already loaded. Are you sure DOpus was not running at all when you tried it? (ie, dopus.exe and dopusrt.exe not present in the processes list in task manager)

Yes, positive :slight_smile:

Okay, this is really weird.

I exited all programs, end task-ed everything I could from Task Manager, tested with a clean DOpus install and Folder Size and it still froze on me only when Folder Size was installed..

Then I decided to test it on my laptop where everything worked fine and kept working fine, no matter which programs were running, which config I used and if Folder Size was installed or not.. :confused:

I don't understand this :frowning: I guess I will have to live with it then until the next clean install of XP.. Thanks for looking into it..!