Folders containing only one .mp3 file not showing as thumbnails

I found that some folders were not displaying as thumbnails even if they contained a folder.jpg within them.
After further investigation I realised that if a folder contains just one music.mp3 file and folder.jpg the folder will not display as a thumbnail.
If the folder contains two .mp3 or more and folder.jpg then the folder will correctly display as a thumbnail based on folder.jpg
When the folder contains only one .mp3 I add a an additional hidden dummy.mp3 file to the folder.
The folder will then correctly display as a thumbnail. For example for the folder to display as a thumbnail the folder will contain: music.mp3, folder.jpg and dummy.mp3 (with hidden attribute).
It's not a great solution but it works. Other file explorers apps display the folder as a thumbnail in all situations so I guess Dopus has a bug that stops it showing the folder as a thumbnail when there is only one.mp3 contained within the folder.

That doesn't seem to be true here. The folder thumbnail works the same as it would normally for a folder.jpg file.

If shell folder thumbnails are on, you should see the same thumbnail as you see for the folder in File Explorer:

Or with shell folder thumbnails turned off:

If you are expecting a CD jewel case thumbnail (unlikely as other file managers don't do that, but just in case that's what you meant), copy or rename folder.jpg to coverart.jpg to force that style of thumbnail for the folder when there aren't enough music files to trigger the automatic detection:

Hi Leo, thanks for your prompt reply. It's strange why my system is behaving differently to what you found. All my music albums folders with just one mp3 all just show the standard folder icon. I then added a additional dummy mp3 file to each of the folders and the the folders displayed as a jewel case.
In addition the thumbnails only display if the folder contains folder.jpg. Cover.jpg or folder.jpeg will result in the folder just showing as a default folder icon, not a thumbnail.
I'm only an average user so maybe I'm missing something simple here?
Thanks, Steve

Are you on Windows 11? Shell Folder Thumbnails don't work in Windows 11, although Microsoft have said they are bringing them back.

That would explain the difference, but you presumably see exactly the same in File Explorer (except File Explorer wont' ever show jewel cases, as that's an Opus-only feature).

Jewel cases are only automatic when the folder has mostly music files. If it only has one music file, you have to explicitly tell Opus you want the folder to display as a jewel case via a coverart.jpg file.

That will be true even if shell folder thumbnails are working. You'd only see the jewel case style of thumbnail for a folder that either has several music files or has a covertart.jpg in it.

Thanks Leo,
I'm so pleased you've helped sort this for me - thankyou. I'm using Windows 11. My settings now are:
I have now turned off "folder thumbnails to the shell if possible" in the folder thumbnails settings.
I use folder.jpg throughout but use coverart.jpg if just one mp3 in a music album folder.
Folders with mp3 music in now correctly show as a jewel case.
Folders without mp3 inside show as a flat folder shape with the picture overlaid.

1 Like