Font install crash

The moment 'Install' is clicked from a font file context menu, DOpus will crash straight to desktop without showing crash dialog.

I can't reproduce that here immediately. Does it happen with all types of fonts or just a specific one? Could you try installing it through Explorer to check it works via that route?

Explorer installs without problem. I've tried three different fonts, they all have caused a crash in DOpus. Since you're not seeing the same on your end, it could just be something funky with my end. I can settle with installing fonts through Explorer from now on as it's rare any get installed anyways. Thanks!

Were any crash dumps created?

Opus 12: Automatic crash logs (for bug reports)

Opus 13: Help > Submit Crash Logs (or Help CRASHLOGS if you don't have the menu item).

Unfortunately, there are none.

Opus crashes when installing fonts via the context menu.


13.0.25 :thinking:
Try the last beta first

1 Like

I've merged this with the existing thread since it sounds like the same issue. @yonder wasn't able to find any crash dumps - can you see if you have any?

No crash dumps here either, happens with otf and ttf files. The installing font dialog flashes for a split second then opus vanishes. Wish I could be more helpful.

Can you try toggling the state of the Preferences / Miscellaneous / Shell Extensions / Access context menus out-of-process if possible flag and see if it changes anything?

I don't see an item in the list with any keywords from 'Access context menus out-of-process'. I tried searching with filter textbox and had 'All' selected to search all the extensions.

It's at the bottom of Preferences / Miscellaneous / Shell Extensions.

Ah yes there it is. It helped, font installation successful!

Did turning it on or off make it successful?

Unchecked did the trick.

Is this a new setting for v13? Is the default setting checked? I don't see myself changing this setting unless directed by someone such as yourself as I don't see the benefit. Thanks.

I unchecked it, it's still crashing.

It seems to be a bug in Windows, but it's random when it does/doesn't crash things. Never crashes for me (Win 10), but for Jon (Win 11) it crashes OOP but not IP, while it's the opposite for other people. Crash dumps show it's crashing in the Windows code when it creates its progress dialog.

We're going to try swapping it out for our own install-font code in the next beta.

1 Like

Not sure what version fixed it, but this was resolved and no longer crashes even with this option ticked.

Preferences / Miscellaneous / Shell Extensions
Access context menus out-of-process if possible