Force file extension display for specific files

I've recently upgraded to DOpus 10.5 and now find that .htaccess files no longer display their extension when "extensions are off". This may sound correct but let me explain...

Previously, with file extensions globally hidden in DOpus by default I could still see the extension for .htaccess files (and similar nameless files that did have a dot followed by the extension).

I cannot remember if I had a unique setting that allowed to to view things this way and, if so, that has now been deleted because of the recent upgrade to DOpus 10.5

My Windows Explorer does still show the .htaccess extension all the time as this is set to always be displayed in the Registry.

I've searche the forum for .htacces and force extension diplay, etc. and can't find anything of help. Is there an simply solution to this problem?


I'm using version 10.5.1 and my .htaccess files display normally when I have extensions turned off.

The .htaccess files I work with have no extensions, .htaccess is the file name. Are .htaccess files to you something other than web server configuration files?

It's my guess that we'd need to know more about how you have Opus configured. How are you turning off the extensions? With a style? A lister layout? Folder options? Any one of those can be set up to hide .htaccess files along with file extensions.

Thanks for the reply.

This morning (before reading your reply) I thought I better test my setup and try and see why my previous version of DOpus (v8 32bit) did display the .htaccess files.

It now seems the problem was due to how things were configured with the new install of DOpus (v10.5 64bit). I had imported my previous settings into DOpus, expecting there to be no problems.

I have now uninstalled and reinstalled DOpus 10.5 and, this time, NOT imported my previous settings. This default install DOES work correctly, i.e. ".htaccess" and any other nameless files (or files named with a dot and no extension, if you prefer), e.g. a file named ".txt" do now display when "Hide file extension in Filename column" is enabled.

I believe that the original problem is related to how I had DOpus configured to display files in Details view but with extensions hidden in the Filename column. I had a button that toggled the extensions visibility in this column which I think must be based on this method: Show / Hide File Extensions

I will try incrementally reconfiguring my setup and see if the problem arrises again. If so, I'll report back in this thread in case it is helpful to understand the underlying issue.

Thanks again.

Thanks for the information, we've been able to reproduce this issue and will have a fix for it in the next update.

Oh right. That's good to hear. I look forward to the next update being available.