FTP Compare and Synchronization not working properly

Dear all, I'm aware that has been reported a bug related to FTP sync in version 13.4 but I'm currently have the same behavior in 13.4.3. This is what is happening:

  1. I try to sync a FTP repository with a NAS folder.
  2. FTP Compare correctly identify the files and folders to sync.
  3. Sync will complete the task.
  4. At this step if I will run Compare again it will show that ALL the existing files and folders need to be sync again, instead of showing "No changes detected or required".

Could you please try to fix this issue?
Thanks a lot in advance

I have updated to version 13.4.4 and the issue is still there.

As far as I can tell this is all working correctly now. Can you please post a screenshot showing how you have the sync configured?

Thanks Jon for the quick reply. I will show you here the screenshot with the configuration. As you can see the compare show some results and will continue to show the same results after the sync. It is the third time that I've tried and nothing has changed:


Can you find those folders on the NAS device after they've been copied?

The common element seems to be [ ] characters in the deepest level pathname and I wonder if the NAS is changing the filename in some way.

1 Like

Hi Jon, I've checked and the filename is identical in the NAS and yes, the files and folders are already there. Even in the previous screenshot you can see that I've flagged the option "Hide unaffcted files" and indeed the NAS window (bottom one) is empty. The result should be "No changes detected or required" but I will see the sync message over and over. Thanks for your support.

I would like to add that I didn't have this issue with version 12. Thanks

Can you post a screenshot showing the same folders/files on the NAS?

Yes, sure. This is one of the files:

Both have the same size, date, etc.

Try turning on Preferences / Miscellaneous / Advanced: [Troubleshooting] sync_debug and do the comparison again. It will write a log to your desktop which might help see what's going on.

Hi Jon, is there a way to privately send you the log?


Click my name and then the Message button to send a PM, or email it to crashdumps@gpsoft.com.au.


I've just sent the log via email.


Should I try to install the new beta version and retry?

Thanks for sending the log, unfortunately it doesn't really reveal anything unusual.

I've tried the same sync using the details in the log and haven't been able to get it to fail, which makes me think it must be something related to your NAS.

Do the other files and folders that are out of sight in your screenshot above also contain square brackets in their names? That's still my best guess as to what might be causing it.

Are you able to try doing the sync to a local folder? (Copy it from your NAS first so you don't need to have to download everything from FTP).

Hi Jon, thanks for the reply. I've tried the following:

  1. Compare NAS to Local Desktop: No issue
  2. Compare to FTP to Local Desktop: The problem persist.

It is strictly related to FTP (all FTPs not this one in particular) and I've sent you the new log file via email.
I don't know what is really changed from v12 to v13 but on the previous version I had no issue and the setup was identical.


Hi, I've installed the latest version (13.4.6) but the problem persist.


Please try 13.4.7 - I was finally able to reproduce the issue and I think it really should be fixed now.

Hi Jon, you're a star. The problem has been solved. Thanks


Thanks for helping us track it down!

1 Like