FTP compression "for all transfers" not working

I am trying to use compression on vanilla FTP. For my site properties in Opus, on the Special tab I have it set to "ZLib for all transfers".

When I login to the FTP server, I see it set "MODE Z", and when Opus requests directory listings, the server side shows the compressed streams being sent.

But when I fetch a file through Opus, it sets "MODE S" prior to doing so in spite of my setting. If I upload a file, it doesn't specifically set any mode first, but after it's complete it sets MODE Z again before refreshing the directory listing.

So it seems like it's acting the same as "ZLib for LIST only".

Bug? DOpus 12.24 x64

Confirmed. We're looking into why it's like that as the change was intentional, but the UI didn't get updated. It's possible there were compatibility issues, but we need to investigate to work out what to change.

Great, thanks Leo.

Looks like this was never implemented, but the UI option was overlooked. At least for now, we're going to hide the UI option in the next beta (12.25.1).

We may look into implementing it when there's time in the future, although with a fairly low priority as the main benefit of zlib here is for folder listings (which are uncompressed by default), since most files that are uploaded/downloaded are already compressed these days and won't benefit from it.

Well, except for people like me. I have a process that generates 256 csv files daily. They have to be downloaded via FTP and then processed into our SQL server. Fun times!

Yeah, in my case I was transferring a ton of uncompressed RGB images with lots of solid areas, ripe for compression, although it was more-so a motivation to get the compression working on my server's side and I was just using Opus to test.