GP SoftwareTwitter
Opus FAQsManualCommandsObjects

FTP Copy File Error


Once per week I copy a 250MB file from our company’s FTP site to our internal server as part of our back-up process. I’ve used Directory Opus to do this successfully for years.

However, since upgrading to version 11, the copy task gets to the very end and then issues the message “An error occurred copying ‘’: Incorrect function. (1)”. (see below)

I have found that if I click “Skip” the copied zip file remains and seems valid, but this error makes me question whether that’s true. As the error has happened four weeks in a row, I thought I’d bring it to your attention.



If you set Preferences / Miscellaneous / Advanced: copy_nonbufferio_threshold = 0 (zero), does the same still happen?

If it does still happen, what does the FTP log say? (Select the FTP -> Display FTP Logs menu item, then select either [All Activity] or the specific site from the drop-down list of logs.)


Hi Leo,

I repeated the copy and it failed in the same way, even after changing the copy_nonbufferio_threshold to zero. Here’s what the log shows:

[quote]250 Rename successful
200 Type set to I
227 Entering Passive Mode (65,254,248,204,237,214)
150 Opening BINARY mode data connection for (270859537 bytes)
270859537 bytes received in 529.140 seconds (499.24 Kbytes/sec)
Connection closed[/quote]
I renamed the file before copying it, so I’m pretty sure that what I’ve provided is all that’s relevant to the copy task. At least here I can see that I’m getting all the bytes!

Curiously, when I copied the file in the other direction (to the ftp site) there was no error.

Thanks for your help,


If you copy the file from the FTP site to a local drive (instead of the network folder), does that work?

What if the local copy is then copied to the original destination (without using the FTP site)?


Hi Leo,

You know how in detective stories they say “there are no coincidences?” That’s a good rule for software, too, But this time I think it really is a coincidence, and DOpus is not the issue.

Copying to a local folder produces the same error. The log looks essentially the same:

227 Entering Passive Mode (65,254,248,204,189,63) 150 Opening BINARY mode data connection for (270859537 bytes) 270859537 bytes received in 529.47 seconds (499.24 Kbytes/sec) Connection closed
Copying between the local drive and network folder works fine, too, but I suppose that’s irrelevant given the above.

I tried the same task from another computer that is still running DOpus v.10 and now see the same error. Perhaps this suggests that the source ftp site changed somehow right around the same time I updated to version 11. I’ll just have to deal with one extra mouse click.

To test that thought, I copied a large file (189MB) from another ftp location and did not get any errors.

So, I’m now inclined to believe that something changed on the original ftp site (over which we have little control) and that it was in the same week that I updated to DOpus 11.

Thanks for the help!