Ftp does not work

error message:

socket() - WSANOTINITIALISED: Successful WSASTARTUP not yet performed
** WSA returns ERROR **

"WSASTARTUP not yet performed" indicates one of the following is likely:

[ul][li] The WinSock DLLs are damaged on your system. (Unless WinSock DLLs, or things pretending to be them, have been placed into the Opus directory, this would probably affect other applications, so may be unlikely if other FTP clients seem to work OK.)

[li] A firewall, antivirus or similar piece of software is blocking Opus from making WinSock / networking calls.

[li] A 3rd party shell extension that gets loaded into Opus (and Explorer, File Open dialogs, etc.) is uninitialising WinSock, possibly due to a bug. (e.g. If the extension initialises it once, then un-initialises it twice, it will break the main initialisation.) Extensions related to cloud storage and online version control would be most likely to do this. ShellExView can be used to see which extensions are installed on your machine and disable them. You need to fully exit Opus (via File / Exit Directory Opus, not just by closing all open windows) and restart it for changes made with ShellExView to take effect.[/li][/ul]

Disabling 7-Zip Shell Extension solved it.

That's a strange one. I have that installed (7-Zip 9.20) and have never had problems with it, and AFAIK it has no reason to access the internet.

Well, it was not 7-Zip at fault. It started to work because I restarted Opus according to your instruktions. After a while this error message turned up again, and after restart, it works.


That suggests a shell extension is uninitialising WinSock. In recent versions, Opus itself only initialises WinSock at startup and uninitialises it at shutdown, so any change is coming from an outside component.

Anything to do with cloud storage would be my suspicion. Several of the cloud storage shell extensions, even from major companies, have tended to not be particularly well written in our experience.

Well, Opus should work with google drive and dropbox. You cant beat them. All other ftp clients I have works, native clients, ftp clients in development tools, etc.

If their code is doing illegal things, it's going to break things. Nothing we can do about that, except block their code from running inside Opus. (You can try that yourself using ShellExView.)

Most standalone FTP clients do not allow shell extensions to run inside them, so would not be affected.

I'm afraid you'll need to use ShellExView and start disabling things to track down which component is causing the problem. Investigation can then carry on from there, possibly directed at whoever made the component (but if we know which component to try, we can also see if we can reproduce the problem and confirm what is happening for sure, to make the case stronger when reporting problems to other people, or perhaps it will reveal something that Opus is doing wrong or can work around on its side, but it's more likely the shell extension is simply calling the WinSock API incorrectly and breaking it for everything else in the same process, including Opus itself).

(Similarly, a shell extension could have a bug where it writes random data to random parts of memory. There have been cases like that. We could not do much about that either, except try to prevent the extension from running, and report the bug to the authors in the hope they would fix it. That this apparent bug in a shell extension has a less drastic outcome does not make it any easier for us to magically fix when the problem is almost certainly in a 3rd party DLL and code we have no access to.)

Please try the 11.16.3 beta as we have made some changes which may help with this issue.

Just wondering if anyone who had this problem has tried 11.16.3 (or 11.17 now) and had any feedback on whether the problem is resolved or not?