GP SoftwareTwitter
Opus FAQsManualCommandsObjects

FTP upload just stalling


#1

Hey there,
So just trying to figure out why ftp is not letting me copy up files.
static%20not%20copying

Its working in Filezilla and I have cross referenced the settings, don't see anything out of order. It's just doing nothing, copying up one file. Download and navigation and other file operations are all fine.
Where should I be looking ?
Thanks.
Alan.


#2

Have you tried switching on PASV mode as the log message suggests?

PASV usually works better these days, unless it's a server on the same LAN as you (in which case it still should not work any worse).


#3

Yes checked that, it was on automatic settings, and manually made sure it was on too.
Same deal, just stuck on progress bar and times out.


#4

Does downloading work? Or is that also failing?

Any firewall software etc. that might be treating Opus differently to the other program?

When testing, was it the same file uploaded to the same place in both programs?

Is it a server we can access to try ourselves?


#5

Hey Leo, no issues with download and navigation etc, just upload. Same file, any file to the same place. Sorry I have to leave work now. May email next week if that's ok, thanks a lot. Its copying up a zero byte version of the file after timing out.

Tks
Alan.


#6

Hi Leo, I never solved this but I do think it could be a security issue where I am, and Filezilla goes through the firewall and Opus doesn't.


#7

Hi Leo if possible - could I give you details to check if you can FTP via Opus? to see if it is an Opus config issue or my firewall?
Thanks
Alan.


#8

Please email them to leo@gpsoft.com.au

If you want some extra security, you could put them in an encrypted zip, email that, and send the password here via private message.


#9

Hi Alan,

Using the test login details I was able to upload a couple of files or similar or larger sizes without problem.

I named the PNG file the same as in your screenshot for the upload, on the off chance the filename mattered, then renamed it slightly afterwards to ensure it didn't get confused with a real file. (Although I then deleted the opus_test dir entirely after taking the screenshot, so the rename was a bit pointless in hindsight :slight_smile: .)

That was done with PASV mode on, since direct connections wouldn't work through my ISP.

Let me know if I can test it in any other way, or provide anything from this end that might help track down where the issue is.


#10

Thanks a lot for checking, they must have some rule specifically in a script or something that only allows certain software - ie. Filezilla. Ill keep chasing them here.
Many thanks for checking.