GetSizes with Cloud Folder

I understand that files within a cloud structure may be physically downloaded locally or just mapped back to the cloud but I see that GetSizes reports all folders in a cloud directory as containing zero bytes whether or not any files are present locally. This may well be intentional but if so then perhaps the documentation should say so.

Which cloud software? Doesn't do that with Dropbox, Onedrive or Synology.

It does for me. Both Synology and Onedrive using 12.21.2 Beta. All of the folders in the screen grab have downloaded content.


I just tried with a vanilla Opus config and sizes show correctly so now I will trawl through my scripts and preferences to see if I can track down the culprit. I will report back.

Preferences / Folders / Folder Behaviour / Ignore junctions and softlinks when calculating folder sizes may be relevant.

The GetSizes command also has an IGNOREJUNCTIONS argument which can override the Preferences setting.

Is that the built-in Size column or a script column? (You can tell by the category it's under.) Scripts shouldn't affect it unless it's a script column (but a script could add its own column which looks very similar, so it's still possible).

Good catch @Leo. That's it.

1 Like

This seems to be a bug triggered by the changes in the previous beta; in the next beta you'll be able to turn that option back on and still get sizes in cloud folders.