Hello All,

I have the following problems which I think they're related to one cause and only my system (Vista):

  1. Icons beside text in Folder Tabs doesn't apear.

  2. If I use the Status Bar's icon codes {i:dir}, {i:file}, or {i:.ext}, nothimg appears in the status bar.

  3. If I use *.png images in the Images section of the Preferences dialog, no image is used as background. While, if I use *.jpg or *.bmp, everything is OK.

Note: Problems 1 and 2 don't appear on XP, but 3 appears.

Could someone kindly give some hints on how to solve or troubleshoot these problem?


Have you got the latest drivers for your graphics card? It sounds like certain painting modes aren't working.

Dear nudel,

Actually, when I copied the stocked *.png images from DO \home\images folder to another partition, DO accepted them as background.

I doubted that Vista's UAC may be the culprit. (I'm already logged on with administrative account with UAC enabled)

So, I logged off and logged on again with the built-in
Administrator account after enabling it (this account has no UAC restrictions as if UAC is disabled).

Now, everything is working OK, *.png images (I think it's location problem not image type one), Folder Tab's icons, and Status Bar's icon codes.

Could you please confirm if this is a Vista's UAC problem or DO's problem? And how can I circumvent it, as I don't wanna disable UAC?


Sounds like the file permissions on C:\Program Files\Directory Opus (and below, and maybe above) are messed up.

Could you paste some screenshots showing the Advanced Security Settings windows you get from clicking Advanced in the Security tabs of the Properties dialogs for:

C:\Program Files
C:\Program Files\Directory Opus
C:\Program Files\Directory Opus\Images

and also for one of the images itself?

i.e. The windows which look like this:

Here is a screenshot of the security dialog od Dopus folder.

As you can see all permissions are inherited from %ProgramFiles% and the image folder and all its contents inherit the same permissions.

Although, I'm members of the Administratos local group and this group has full control as you can see, I also put an explicit ACE permission to my own account and give it Full Control permission on the Dopus folder and propagate the permission to all subfolders.
Actually, this allowed me to use the images under the Dopus folder, but the other icon problems haven't been solved. (I even installed Dopus on itself with this permission but no way)

Anyway, it's strange as my account and the Administrator account are members of the Administrators group and the permissions are controlled by the group not individual members.

So, my guess is that it's a problem with the Vista's UAC.

Thanks for your continual support.

Dear Nudel,

Eventually, I found where the problem is (almost).
Actually, I decided to disable Vista's UAC temporarily to solve these problems, but surprisingly the problems weren't solved, so I doubted it may be my profile, so I backed it up and let Vista create a new one, and voila everything is working OK.

The problem now is that I have a lot of settings in my profile and don't want to get rid of it that easily.

Actually, it's only DO that has a problem with my profile, so if you or anyone involved can kindly tell what settings in my profile are accessed by DO and cause these problems which are solved by changing the profile, I'd be grateful.

Thanks again for your prompt support!

It sounds like the Images folder wasn't permissioned properly. The permissions on the "Directory Opus" folder shown in your screenshot look fine, so try forcing them to propagate down to the files and folders below.

To do that, click the Edit shown in your screenshot, then turn on the Replace all existing... checkbox at the bottom (both checkboxes at the bottom of the Edit dialog should be turned on) and click OK.

You say the icons still don't work, is that even after restarting Opus? Are the icons in the same Images folder as the background images?

With UAC turned on your account's Administrator membership is effectively removed except in "elevated" processes (i.e. after a UAC prompt). This shouldn't matter for reading files though as the Users group (which your account is also a member of) is granted Read & Execute access.

I double-checked that Opus isn't doing anything silly, like trying to open the images with write access when it only needs to read them, and I couldn't find any problems so I think it must be a permissions issue on your image files.

It might be worth using Process Monitor to see if any ACCESS DENIED errors occur when you tell Opus to use a particular icon or image.

Dear Nudel,

You're totaly right. Although I didn't post the other screenshots (because they were identical to the one above), after I repropgated the permissions, I was able to use the images.
Thank you very much, I always had confidence in your solid knowlege and troubleshooting talent.

Now, for the icons in Tab Folders and Status Bar, I found the culprit and seems a bug in DO 9 on Vista. Oh, it took me ages to find.

If I change the height of the Titlebar of a Window in Personalization dialog from its default of 19 to any value, the icons disappear, and returns if I revert to default value.

Could you please reproduce this?

Note: Tested on Windows Vista Basic and Windows Standard themes


It does not seem to happen on with Aero Glass enabled but if I switch to Windows Vista Basic, change the titlebar font and titlebar size to 10 and 20 like in your screenshot, and then restart Opus then I do see the same as you, no statusbar or tab control icons. Weird. I'll let Jon know.

Thanks man, I hope there is a fix for this as I don't have Aero, and can't live with these small fonts on high resolution monitors.

Best reagrds,

The icon problem is fixed in Opus[ul][li]...[/li]
[li] Fixed rendering problem with icons in status bar and folder tabs when window title bar height set to non-standard size[/li]
[li]...[/li][/ul]Full list of changes here: [Directory Opus

Awesome, you all rock :opusicon: