High memory and CPU usage during VS2010 unit tests

I have a very odd problem going on here. Opus is saturating one of my CPU cores and chewing through memory at a rate of knots - currently around 14GB and climbing - and is completely unresponsive. The only way to regain control is to kill it off using the Task Manager.

This happens pretty much every time I run unit-tests in VisualStudio 2010. I cannot see the link, but I have not seen this behaviour from Opus prior to starting to write these tests a few weeks ago, and I haven't yet seen anything else trigger it.

I have no plugins installed in Opus - it's a clean OOTB installation - and no shell-extensions of which I am aware that could cause this.

Has anyone seen anything like this before?

Do you have some anti virus installed by any chance?

Oh, sorry, i overlooked your comment about VisualStudio. There is a FAQ on this forum desribing how to hunt down issues like that using
ProcessMonitor, i think. Or Sysinternal´s Process Explorer also might be helpful for some in depth check of which thread is causing the problem.

If you set Preferences / Miscellaneous / Advanced: no_external_change_notify to True, does the CPU and memory usage go back to normal?

(If not, does it do so if you fully exit Opus and then restart it?)

Opus is unresponsive - it can only be killed via the Task Manager. After restarting it, things are back to normal - at least until the next time it happens.

I'll try changing that setting and report back.

Nope, no difference.

The memory usage seems to be topping out at around the 14GB mark, possibly because - once you factor in the memory being used by other processes - that's when it's reached the amount of physical RAM in the system.

Does that happen even if you close all Opus windows but one, and in that window you navigate to an empty folder and turn off the folder tree?

If you're familiar with Process Explorer then it may be worth using that to see which exe or dll contains the code that is using the CPU. (Ignore the reported function names, though; they are usually red.) It could be Opus itself or a system component, but it may also be a shell extension or similar.

I typically only have the one Opus window open, in dual-lister mode with dual folder-trees. I'll try changing the settings around and see what happens.

No, no change - with a single basic Opus lister pointing at an empty folder, I've just had the same problem.

This may simply be that I haven't seen it yet, but: so far I only seem to get one of these per session. That is, after killing and restarting Opus as described above, I then don't encounter the problem again until after the next reboot. Probably just coincidence, but I'll keep checking.

Do you have any source control shell extensions (SVN, Git, etc.) installed that might be reacting to changes that Visual Studio is making? They could be a factor.

Yes, I have TortoiseSVN installed. I'd have thought if it were the culprit then I'd also see this problem simply by editing files, but I shall investigate further.

Just happened again. dopus.exe is pummeling the CPU, and its stack frame currently looks like this:


Under advanced prefs again, if you turn on all three of these:

[ul][li]no_external_change_notify (as before)[/li]

Then run DebugView, do you see output about changes below the folders VS2010 is working in?

(There may also be some, or even a lot, of output from other programs in there as some programs are very "chatty" with their debug output even if it isn't explicitly enabled. If you reset the latter two settings it should turn off all debug output coming from Opus to let you compare against how things normally look on your system.)

Ok...absolutely nothing from dopus whilst the tests are running.

If you turn no_external_change_notify off again, do you start to see things in DebugView?

Yes - there are numerous changes to files in subfolders of my VS project folder. I can't see anything for the immediate contents of that folder, which is the one I have open in Opus.

Could you post a screenshot of your Opus setup, making all the file display columns visible if possible.

BTW, did you try with the folder tree turned off before, or was it still on when you had just one window pointing at an empty dir?

All tests done today were with Opus looking roughly as it does in the screenshot. I haven't tried the 'minimal' approach again since last night.

Did you ever try with the folder trees turned off?

Presumably the unit tests & related files are all on the local drive(s), not the network drives?

Yes, last night. I had a single-view lister pointing at an empty folder. The problem still occurred.

Yup, everything is in the folder shown on the left, which is a local harddrive.