How can I copy a file with label to other drive?

I copy a file(with label) from E drive, then paste to D drive.
The file on the D drive has no label.
I spent a lot of time label all file. its only work on original drive?


If both drives are NTFS and these options under Preferences / Favorites and Recent / Labels were both on when the labels were created:

  • Enable label storage in the file system (NTFS volumes only)
  • Automatically store labels in the file system if possible

...then the labels should be copied automatically, provided Preferences / File Operations / Copy Attributes / Copy metadata (comments, keywords, etc) is turned on (assuming you are copying them using Opus).

On the other hand, if the labels are not stored in NTFS, then they don't go with the files when they are copied and moved. Instead, the Opus configuration has a label pointing at a particular path, which is never changed or duplicated by itself.

(Both modes have pros and cons, depending on what you want to use labels for.)

1 Like

Thanks Leo!
What if i want to copy a file (with label) from exFAT (A) to exFAT(B) ?
Is there any way to copy that file with label?

There isn't. The exFAT filesystem doesn't support alternate data streams.

1 Like

Thanks! I'll format my drive to NTSF.