How do I get rid of "Open In Directory Opus" from my context

When I right-click on a directory in one of my listers the first choice on the context menu is "Open in Directory Opus".

I dont like it because its over-riding my "d" key for delete... in other words i like to right-click a directory and hit 'd' to delete it... now instead its going by the first open "open in directory opus" and is exploring the directory rather than deleting it.

I want to get rid of this context menu item "Open in Directory Opus" or at least change its hotkey to something other than "D". I have tried doing this through the registry but directory opus seems to be repairing the modification when i restart the system.

what can i do

Settings > Preferences > Miscellaneous > Windows integration > UNcheck Add 'Open in DOpus' ...

As well as the option Christiaan points to, you have to turn off Explorer Replacement mode to get rid of the item.

Hi Leo, I never noticed this, because I don't use Explorer Replacement. But don't you think it's a bit strange?
One has to disable Explorer Replacement to get rid of a context menu item (also when the item is already disabled in preferences) ...

It's because Explorer Replacement adds/sets the default verb (usually just "Open") for folders, and the context menu shows the default verb in addition to any context menu items.

problem is... this isn't how it used to work... i just rolled back to 9.1.3.0.3449.x64 ...

you aren't required to set explorer replacement mode... you can just check/uncheck that option under windows integration... which doesnt even affect folder context menus inside dopus... which is logical because why would you need that option displayed when you are already browsing the folder in opus

it seems things are taking a step backward going from 9.1 to 9.5 ... should i file a bug report ticket ??

You're right that it has changed, though only inside of Opus.

Outside of Opus, even in 9.1.2.0, if Explorer Replacement was on then you'd get the "Open in Directory Opus" item in bold at the top of the context menu.

Inside of Opus that same menu item seemed to get renamed to just "Open" in 9.1.2.0 but in 9.5 it's now shown the same inside of Opus as outside. (i.e. it's called "Open in Directory Opus" in both places now.)

Yes, file a report if you want the old behaviour back. Include a link to this thread so GPSoft can see the discussion/details.

(Out of interest, why not just hit Del to delete the selected folder without opening the context menu? Just a 'muscle memory' habit? Fair enough either way; I'm just curious.)

I agree that right-click-D should Delete something, not Open it, and it shouldn't depend on what content is selected.

With this change, right-click-D deletes files but no longer performs the same function on directory entries. I have toggled the "Open in Directory Opus" setting to no avail, but after using DOpus for years I don't think I can live without "Explorer Replacement (recommended)" mode.

This seems to have changed somewhere between 9.1.3.0 and 9.5.5.0 (64-bit, anyway). Please bring back the previous behavior -- or at least change the relevant hotkey back to "O" as in "Open".

My reasoning for hit hitting , BTW, is probably muscle memory. We use both the keyboard and the mouse every day, and when I'm selecting files to be deleted I'm using the mouse to do it (yes, I'm right-handed). I don't want to select files with the mouse and then be forced to move my right hand from the mouse back to the keyboard to press and then back to the mouse to continue working -- when my left hand has a finger sitting right there on the key, all day long, anyway. And it certainly doesn't make sense to make the user perform this same function in two different ways depending on whether he's deleting files or directories!

If I had a video game that required me to use both the mouse and my right hand, say, to move or look or something, you can bet I'd be remapping keys. One can get lots of work done if one doesn't have to constantly bounce back and forth between the mouse and the keyboard for individual functions (say, deleting a file).

Did you know most of the letters used in the most common words in the English language are located under the left hand? (And do you know why that is?) Further trivia: the longest word you can type on a US standard QWERTY keyboard with one hand is the word "stewardesses", and it uses the left hand. Meh, FWIW.

Makes sense. I hadn't thought of someone right-clicking with one hand and pushing D with the other. (When I'm using the mouse I select stuff and then click the Delete button on the toolbar, but that involves moving the mouse so, yeah, fair enough.)

I'd suggest sending a request to GPSoftware to ask if the D key on that menu item can be changed to something else to avoid the conflict with the Delete item.

(I've not thought about it for long but changing it to 'O' might make sense as it's meant to replace the Open item anyway. Or maybe it doesn't need a key at all when Opus is replacing Explorer as it's at the top of the list then and people can just hit return.)

of course this is exactly the reason i posted this... my hands are on the mouse and the left side of the keyboard... there is no delete key on the left side of the keyboard...

i have just sent a request and reported this as a program anamoly and i hope that dopus looks into it and remedies this situation. if they want to keep the program working that way AT LEAST give the rest of us an option to disable that item from the context menu. if i'm already in dopus and i right click on something why would i need a context menu item giving me the option to "OPEN" something in dopus WHEN I'M ALREADY IN DOPUS

i hope this is taken care of soon

Hmmm... I'd have thought that you could just edit the HKEY_CLASSES_ROOT\Folder\shell\openindopus key and remove the & character in the Default string value in front of the word Directory... I seem to recall this is what sets the accelerator key for context menu and menu bar items... But it looks like Opus RESETS it upon program startup. Weird... I'd not have expected it to do that.

We will change this in the next version - but until then, you could make that change and then edit the permissions on the key to prevent Opus from modifying it next time it runs.

Sounds very interesting Jon.
Looking forward to context menu hotkeys ...

@Steje
Good to see you post again.
Well, back to the math logic of Opus now, or Geodomes, :laughing: ... or the rust on my rear springs and axle.

Edit Note: Sorry Jon , I wasn't seriously suggesting that.
I know it's really a windows thing.

Thanks for this... the change has been driving me nuts. I thought it was some hotkey software I might have installed that was doing it. It's not in the DOpus help search either.

I like using Right-click + D for folders because it's the same behaviour as with files. I'm using 9.5.0.0.3565 and removing 'Open with DO' works in 'Replace for all folders' mode.

I configured my context menu, and this 'Open In Directory Opus' while I'm using Opus is the only thing that refuses to die.
This is an old post, so maybe it's different, because the fix didn't work.
& key is gone and my user and system has only read permissions. Restarted Windows Explorer and it's still there.
DIE

You can turn it off via Preferences / Miscellaneous / Windows Integration, but only if Explorer Replacement is off. It’s required if Explorer Replacement is on.

Fine. I'll put the registry back and just suffer it.

Just a quick question regarding this. Given that Open in Directory Opus must be enabled for explorer replacement to work, would it be possible to treat it like windows context menu entries when the user enables the "Hide windows and other third-party items on file context menus" option? By that I mean hide it from the context menu unless the user adds the FileType CONTEXTMENU CONTEXTOPTIONS=windowsonly command, which would allow them to control where it appears.

Convention is show the double-click action at the top of context menus in bold, so it'd be unusual to hide it within our own process where it is the default (and usually the only action of its type shown if the "hide..." setting is on).