How do u stop "auto-refresh"

In standard WinExp, if you change a file's attribute (ex: the file name), the display is not automatically re-freshed. But in DOpus, the lister is refreshed automatically. I've searched all over the preferences but can't figure out where this is deactivated. How do you turn it off?

This is somewhat annoying because if I rename a file within a folder containing a large number of similarly named files, it's difficult for me to see where the file was "moved" to (based on the sort), because I'm not seeing any movement in the display (i.e., other files moving down 1 space).

Cheers.

hi there nate... my 2 cents:

  1. Disable (uncheck) the Automatically sort new and modified files option in Preferences->File Operations->General page...

This sounds like what you're after as it will cause the renamed file to remain in it's current position - requiring you to hit refresh manually to sort it in the file display.

  1. Whether or not you leave that option enabled, you could also add the @nodeselect argument to whatever rename functions you're using... whether or not the file is then automatically sorted, it would stay 'selected' after the rename so that it would stand out more obviously while scrolling through the file display to find it again.

I think the first option is what you actually wanted, I just mentioned the second as an alternative, because hitting manual refresh will then deselect the file.

Thanks. I'll try and implement your second solution because that's more in line with what I want. I don't really mind the auto-refresh (because 99% of the time, I hit F5 anyways). It's the loss of focus that my brain processes more easily with WinXP than with DOpus.

Thanks.

Well, you could actually combine options 1 & 2. This will make it so that once you'verenamed the file, it will NOT be sorted into the lister, the lister will stay positioned on the file in it's current location in the file list, and the file will be highlighted/selected after the rename?

I think Steje has the answer here,
but there may be an alternative solution since apparently the rename is done from a function.

Preceed the rename command with:
Go TABDUPLICATE
SELECT HIDEUNSEL NOPATTERN

The renamed file(s) would then appear in a new tab.
It avoids disabling the autorefresh.
I'm using it in a button now and haven't run into any problems with
SELECT HIDEUNSEL NOPATTERN completing execution before Go TABDUPLICATE does.

Actually, I use it with a Copy Move ADDTOZIP Here ,
but it's really just me playing with commands and buttons.

:opusicon: porcupine

Upon a bit more thinking,
I've found that the NEWTAB is an unselected copy of the original Tab.

SELECT HIDEUNSEL NOPATTERN
occurs in the original Tab, witch remains selected even after a Go TABDUPLICATE begins or ends execution.

So everything is fine no matter what the order of the command execution completion,
as long as the rename command acts on the selected files in the original Tab.

The commands were originally executed from that Tab.
Could it be that focus of function execution remains in the original Tab instead of shifting to the NewTab ?
The NewTab does have focus after it is created.

:opusicon: porcupine

edit note:
This post was modified while others were reading it.

edit note 2:

Ahhhh... That's the mistake.
The original Tab retains focus.

I have it all working now.
In the end it turns out that Dopusrt /cmd is needed in conjunction with the rename command.
Otherwise, multiple file selections result in multiple duplicate tabs.

A zip example:

Go TABDUPLICATE
SELECT HIDEUNSEL NoPattern
Dopusrt /cmd Copy Move ADDTOZIP Here

A rename example:

Go TABDUPLICATE
SELECT HIDEUNSEL NoPattern
Dopusrt /cmd rename Pattern=".mpg" To "_old.mpg" Findrep=ext

:opusicon: porcupine

I finally got around to doing this and am expierencing a small issue.

I've activated the [automatically sort new and modified files] indicator because it was the loss of focus that was more of a concern. I've also added the @nodeselect statement to the standard rename button and modified it slightly like this...

Rename INLINE=all
@nodeselect

This will keep the focus on the renamed file but it still keeps the "soft focus" (I don't know what else to call it) on another file... there is a dotted line outlining another file and a complete shadow "selection" around the recently changed file. So if I immediately hit F2 again because maybe I mistyped the filename, it starts to rename this other file, not the first one. Am I missing a command?

Thanks.

Confirmed... it looks like the file that gets the 'soft focus' is whatever item that inherits the place of where your selected file was positioned in the file display before you renamed it (that is... if the rename causes it to be resorted in the file display - i.e. rename b.txt to 0.txt in a folder that contains a.txt, b.txt, and c.txt). Oddly enough, hitting Enter will open the file you renamed and still have fully highlighted... unlike what you see happen when you try to rerun an Opus function like rename... Not sure how to change this behavior. I tried a few options in Prefs, but saw no change :frowning:.

If you turn off Automatically sort new and modified files then the file won't move around after you rename it with F2, which means the file will retain the focus (the dotted rectangle) which is what inline-rename always acts on, and so you can press F2 again to inline-rename it again if you need to.

If the focus did move with the file when the file was renamed it would make it really hard to inline-rename a bunch of files one after the other.