How to add context menu of Alcohol? (Opus 12.20 x64)

How to add context menu of Alcohol? I've done the settings below, but it doesn't work. Thanks.

Assuming you're using the 64-bit version of Opus, the {AF... one is the 64-bit Alcohol extension, and the one to try in the second screenshot.

The {32... one is 32-bit and won't work in 64-bit processes.

If that still doesn't work, it's possible their shell extension has been changed to only add items into certain processes (maybe because it has had so many issues with crashing inside other processes over the years).

A good test for that is to see if it appears in Notepad.exe's File > Open dialog. (That will tell you if, for example, it only appears in explorer.exe and nothing else. But it's also possible they are blocking processes by name rather than allowing them, or that there is some other reason it isn't working.)

Also, which file type's context menu are you adding that FileType command to?

Note that you may find Alochol's shell extension causes instability, so re-enabling it may not be worth the hassle. If it has a command-line interface, a better thing to do would be to make Opus context menu items which use that to ask it to do things, bypassing its shell extension.

I changed to {AF..., but it still doesn't work. I added the FileType command to All files. Are there any solutions for this issue?2020-06-18_171916

That should work (unless you're right-clicking a drive of folder).

Do the Alcohol menus appear when you right-click something in Notepad's File > Open dialog?

Alcohol menus don't appear.

I hope when right-clicking an image file supported by Alcohol, a Mount menu will show up as the image below. Besides, the icons of image files can appear correctly in Opus.

If the menus don't appear in Notepad's File -> Open dialog it suggests they are deliberately hiding them from anything other than Explorer.

Is there any way to solve this problem? Alcohol works well in Windows Explorer. :disappointed_relieved:

Talk to the people who make Alcohol, since they’re the ones who are presumably preventing it from working.

I think it's caused by Opus since Alcohol works well in the older version of Opus.

Opus wouldn't stop it from working in the Notepad File > Open dialog. Something must have changed in Alcohol.

I see and give up. Thank you.

Why not ask the Alcohol developers? They are the experts in their shell extension.