How to adjust Enter-key behaviour, if at all possible?

I have PowerToys Keyboard Manager running. It remaps the [Enter] into [Shift][Enter].
Reason is that whilst exchanging mails from Outlook to Gmail, the replies from Gmail show double line spacing when using just [Enter] in Outlook.
So Gmail 'requires' Outlook users to use [Shift][Enter] to avoid this stupid double line spacing.
The choice is: either adopt this shift-enter or use a keyboard manager.

Regretfully this affects the behaviour within Opus. It will open the 'Go'-bar/box.

SnagIt-17032022 093646

Wonder whether the behaviour of the Enter key can be changed without adding a button.

Tried Power Mode : enabling 'Enter key opens all selected files', but did not help.


Later: [Enter] to do the same as double click

Why not set it to just remap the key within Outlook? Changing the behaviour of your Enter key system-wide to solve a problem like this seems like a fairly radical course of action :slight_smile:

1 Like

Much has been written about this so-called 'double line spacing'. AFAIK Outlook does not offer a solution.
Regretfully so. One needs to seek for workarounds, like PowerToys or some AutoHotkey script. Yes, it is radical solution, applications like Excel include an optional setting as to how 'Enter' key would behave.

I mean use PowerToys as you are now, but set it to only change the key for Outlook, not for everything.

Fix or replace Outlook rather than break what your keyboard does in the entire OS and have to find ways to un-break it in all the other applications.

Or find a way to change what the keyboard does only when Outlook is the active window, which should be possible. (AutoHotkey can probably do that.)