How to Attach e-mail files via Opus, not Explorer

Hi,
I use Thunderbird e-mail and I am trying to attach a file (it's a photo) to send--but when I click attach it sends me to My Documents which is hiding most of my photos/scans.

I want it to access my files via Directory Opus (which shows everything and will bring up the photo/scans). I would like Explorer to go away, actually.

Any suggestions.

Thank you.

Melissa

Opus doesn't replace the standard "File -> Open/Save" dialogs, but if you want to use Opus to select the attachment there are a couple of ways you can do so easily:

  1. The simplest way is to simply drag a file from Opus on to the Thunderbird message window. (At least, you could do that the last time I used Thunderbird.)

  2. You could also select the file in Opus and then use Edit -> Copy Filenames -> As Full Pathnames, then paste that path into Thunderbird when it asks you for the attachment.

So the files to be attached are in My Documents?

I don't know the answer, but is it possible to attack this problem from the point of view of why the files are being hidden rather than from the direction of Opus?

When I want to attach a file to an outgoing Thunderbird email I use Opus to find the file(s) then I'll drag and drop it to the right side of the email to send. When you hover the Opus mouse pointer over the correct area of the Thunderbird email an invisible box appears and you can drop (attach) your file(s) that way.

You can do a similar thing in Outlook only you don't have to look for an invisible box, just drag and drop from Opus into the email body.

Thanks for all the suggestions.
I'm going to start with dragging Opus file to the message window and see if that will solve it.
Melissa

First time in this forum. Forgive me if I am doing it wrong.

I use Outlook for my e-mail. I commonly right-click on a file on my desktop or Windows Explorer and then click on "Send to" and then "Mail recipient." This puts the file in a new Outlook message. I enter the recipient's e-mail address, add some text and click on Send. The file get sent. None of this works with Directory Opus.

I have also tried using DO's icon for e-mailing files, but that does not work either. Any ideas on how to e-mail files that I select in Directory Opus?

Rob

Which version of Office do you use ? I have Office XP (2002) on XP, and like you, i can join file to mail via Opus.

If you have told DOpus to hide Explorer's context menu, then hold down shift and right click and you should see the usual "Send To" options, including Email.

What actually happens? Is the menu item there? Does anything happen when you select it? Does an error message appear? etc.

FWIW, it also works here with Office 2010 (32-bit) on Windows 7 (64-bit) with Opus 10.0.1.3 (64-bit).

In answer to the questions sent back to me (and thanks for that)....

When I select any file in Directory Opus and right-click on it, a window opens and I then click on "Send to." Another window then opens, and I click on "Mail recipient." Then, NOTHING happens. If I do the same thing in Windows Explorer, Outlook opens with the selected file attached.

michaelkenward wrote "If you have told DOpus to hide Explorer's context menu, then hold down shift and right click and you should see the usual "Send To" options, including Email." As stated above, I already see the "Send to" and "Mail recipient." But after that, nothing happens.

Michael, how would I have "...told DOpus to hide Explorer's context menu?" Should I change a setting?

AlbatorV wrote "Which version of Office do you use ? I have Office XP (2002) on XP, and like you, i can join file to mail via Opus." I have Outlook 2003 on my Windows 7 computer.

Any ideas, folks?

[quote="RobertEves"]Michael, how would I have "...told DOpus to hide Explorer's context menu?" Should I change a setting?
[/quote]

You can change it, but you might prefer just to use the Shift trick to get at those options.

Here's how to change it:

Settings
Preferences
Miscellaneous
Windows Integration
Hide Windows items on file context menus.

Uncheck it.

But that isn't going to fix the fact that it doesn't work at the moment.

Are you sure that you have not overridden the handler that Windows uses for email?

You can check this in DOpus.

Settings
Filetypes
System File Types

In the "Extension (NONE)" list you will see "URL:MailTo Protocol"

That should be Outlook with a complicated set of "switches" at the end. Sorry, I gave up on Outlook 2003 some years ago. So I don't know what that should be.

You say:

A window opens when you right click? Do you mean a menu appears?

If you know which files you are likely to want to email, then you can add your own context menu item for just that "File Type Group". For example, if you only want to send documents, then you can edit that File Type Group and add a context menu button. All it needs is:

"Copy SENDMAIL"

If you are likely to send files of all types, then add that to the context menu for "All Files". I don't do that because I don't want to clutter up the context menu.

There are bound to be simpler ways of doing all this. But this one works for me.

Michael:

My, gosh, you know this program! I'll respond to each of your points.

">>Settings

Preferences
Miscellaneous
Windows Integration
Hide Windows items on file context menus.

Uncheck it."

It was already unchecked.

"In the "Extension (NONE)" list you will see "URL:MailTo Protocol"

I found it. On the panel below, it says "Opens with Office Outlook" When I click the Edit button, there are 5 "Actions" shown. All are marked " except the action called "open." That one has this in its field: C:\PROGRA~1\MIF5BA~1\OFFICE11\OUTLOOK.EXE -c IPM.Note /m "%1"

This is Greek to me. It can be easily changed, but I would know to what.

  1. "A window opens when you right click? Do you mean a menu appears?"

Yes, a menu appears, and "Sent to" is one of the menu options.

  1. "If you are likely to send files of all types, then add that to the context menu for "All Files".

Yes, I send all types of files by e-mail. Are you saying to go to:

Settings
Filetypes

Then find "(NONE) All files"? It's at the top of the long list. Then am I to click on the "Edit" button? Then am I to click on the "Context Menu" tab? Then am I to click on the "New..." button? Then in the "Action" filed, am I to type "Copy SENDMAIL" (without the quotation marks)? Maybe I am on the total wrong course. Set me straight, Professor.

I wonder why the "Send to", "Mail recipient" function does not work in DOpus. I can right-click on any file of any kind from Windows Explorer or my desktop and it works fine. I think it worked in the prior version of DOpus, too.

On my copy of DOpus, there is an icon on my toolbar called "Send selected files as email attachments." When I click on it, a window opens with the heading "Send Email - Directory Opus." There is a field to enter an e-mail address, but it does not "remember" all the frequently used e-mail addresses like Outlook does, so I then have to go to Outlook and look up the desired e-mail address and paste it in. When I then tell it to send the e-mail message with the selected file attachment, I get this error "eves@venture-corp.co... - SMTP error - 535 5.7.3 Authentication unsuccessful."

Sorry to be such a bother, Michael. This seems to be such a simple undertaking that I use multiple times a day, yet in OPus for me it seems impossible.

Regards,
Rob

No bother at all.

Your Outlook setting seems to be the right one.

You also seem to have got the steps right to add your own menu entry.

As you can probably tell, I am flailing around a bit. Like you, I can't understand why mailto does not work in DOpus.

One other thought.

If you go to Settings, type in "email" in the bottom (find) slot.

It should throw up "Email" settings. Is it set to Send email via "mailto:emulation"? (It is a subset of the "Internet" menu in Preferences.)

The behaviour you see suggests that it may be set to "internal smtp client".

For what its worth, I send attachments routinely with Send To->Mail recipient here with Dopus 10 and Thunderbird. So it does work.

I wonder if any A/V software is intercepting the calls to make a new mail document w/attachment.

Hi, there is a solution. Same issue bugged me as well as I am used to sent items using right-click mouse button.
In Opus go to Settings>File Types
scroll down to System File Types>NONE URL:MailTo Protocol
Choose Open, click edit, copy application line and click cancel.
now scroll to the top and Under Directory Opus File Types choose the first one "(NONE) All files"
click edit
Choose Context Menu tab
Click New
Give new command a name like "Send as attachment" for ex.
paste the text and change Microsoft Outlook switch to /a to look something like that,
in my case: "C:\PROGRA~1\MICROS~1\OFFICE11\OUTLOOK.EXE" /a "%1"
leave function as is "Standard Function (Opus or External)"
click OK and OK again.
Now when you right click any file you will have "Send as attachment" in context menu.
I am sure you can do the same and revive the old Send To menu, I just prefer the command not to be buried too deep in sub-menus.

Greetings. You have done it!

The process worked, and now my goal is to try to understand why. I can now right-click on a file and select "Attach to Outlook e-mail" from the menu, and it works perfectly. I am going to re-trace all your steps in the hope of understanding the lesson. Have I essentially created a command that operates in DO?

Now I want to try to figure out how to put an icon on my toolbar that I can click on that will automate the process, if that is possible.

One more question, Professor... On your instructions, you wrote "paste the text and change Microsoft Outlook switch to /a to look something like, in my case: "C:\PROGRA~1\MICROS~1\OFFICE11\OUTLOOK.EXE" /a "%1"

I did as you instructed and found that my line looked like this: C:\PROGRA~1\MIF5BA~1\OFFICE11\OUTLOOK.EXE -c IPM.Note /m "%1"

I changed the /m to /a, as you said. But I was baffled by the folder "\MIF5BA~1" that appears above. Using DO, I confirmed that no such folder name exists. In fact, the actual folder name is the same as yours: "MICROS~1" I recognize that the "~1" is intended as an abbreviation, but what the heck is "\MIF5BA~1" -- I have no such folder.

Thanks for your expert help.

Rob My e-mail: eves@venturecorporation.com

For Thunderbird you can attach a selected file with this command:

"C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -osint -compose attachment="%1"

I couldn't get it working with several selected files because Thunderbird needs to get the paths enclosed in single quotes and separated by commas like this:

...attachment='C:\My Folder\attachment\File 1.zip,C:\My Folder\attachment\File 2.jpg' Perhaps someone can figure out how to pass multiple files to Thunderbird this way.

It's also possible to create the whole e-mail including e-mail adress (using a list of your favourite adressbook-entries with {dlgchoose}), subject and attachment from a button:

@set to= {dlgchoose|choose adress:|adress1+adress2+adress3} @set subject="{dlgstring|Subject:}" @set body="{dlgstring|Message:}" "C:\Program Files\Mozilla Thunderbird\thunderbird.exe" -osint -compose to={$to},subject={$subject},body={$body},attachment="%1"

Thunderbird Command Line Options:
https://developer.mozilla.org/en/Command_Line_Options