GP SoftwareTwitter
Opus FAQsManualCommandsObjects

How To Automatically Open 2 Windows When Opus is Started?


#21

As fortune would have it, I found a monitor that is the exact twin of the one I've always used. And do mean, exact twin, so I don't think it's a DPI conflict or anything. They are both set to the default user profile, and I've rebooted many times...

Here's a screener of the properties:

So, all that looks normal to me.

Well, many thanks for trying to help. I'll just have to keep opening the second window manually, it's not the end of the world...

One thing I did notice, is that in the screener you posted of the saved layouts, the picture of the two monitors in the bottom right are sort of colored in yours, but they are not in mine. Would that mean anything???


#22

A bit of an update... I was looking through my notes on anything I might have set special in Windows 10, and I came across something I set a couple of years ago. I had set the Control Panel \ Ease of Access \ Make the mouse easier to use \ Activate a window by hovering over it with a mouse . I like having that setting in place so that I don't have to click on a window to get it active.

Anyway, just for S & Gs, I unchecked that setting, rebooted, and then saved the layout for Opus once more.

So, here's the thing.. it sort of works now. It won't open two listers when I click the taskbar icon, but when I use the Settings menu and activate the saved lister, it now will open two listers, one on each display and maximized. So, we do have some progress here...

Leo, you said once we get to this point, we could possibly address what could be wrong with starting from the taskbar icon???

UPDATE: I tried something else just as a test. I changed Prefs so that Opus auto starts (delayed) with Windows, and uses that saved DualDisplay layout.

Rebooted, and there the two windows were, one on each monitor. They started maximized, which I would like to change to minimized, but they did start.

2 things... I still don't know why it won't work from the taskbar icon after windows has already started..

More important... how do I now get both windows to start minimized?? I don't see a setting for that one...


#23

After searching first this forum, and then Google, it seems as if Opus will not auto start with windows in a minimized state... Looks like the closest one can get to that is to select to not open any listers when it starts with windows...,

That won't work for me, because I need to open the saved layout, and prefs will not let me open the saved layout, and not open any listers, both at once... That makes complete sense, of course.

The reason I want the listers to open minimized is because once they are open, the other programs that auto start with windows tend to open partially on top of the listers... I don't much care for that...


#24

You can set Opus to run at Windows startup, not open any windows initially, and then open the layout when you want them.

But if Opus is already running, with no windows open, then clicking a pinned taskbar button for it will always open the default lister.

You'd need to use another method to open a saved layout.

  • Double-clicking the desktop is an easy one.

  • Double-clicking the taskbar notification icon (aka tray icon) is another option, if you have it enabled. (This is the icon on the right of the taskbar, next the system clock. It might be turned off, or hidden inside the /\ menu with most of the other similar icons, unless Windows is configured to always show it on the taskbar.)

Those can both be configured under Preferences / Launching Opus.

You can also open layouts in various other ways, but those are the easiest to set up.


I tried turning that option on and was still able to open a layout with windows maximized on both screens.

That's just my desktop background color. The windows in my test layout weren't maximized when I took that screenshot.


#25

I did as you suggested, and changed the settings so that double clicking on the desktop will open both windows, and it works just fine, thanks!

As to this:

I'm wondering if you had that option turned on in control panel before you saved the layout? Because that's the only thing I did to make this finally work for me, was to turn it off, reboot, then save the layout again... After that, things work very well.