GP SoftwareTwitter
Opus FAQsManualCommandsObjects

How To Automatically Open 2 Windows When Opus is Started?


#1

I just yesterday came across a second monitor that I can use with my computer. So, I'm very new to dual monitor life, and of course, Opus is my most important, prime program that I use. It gets started before anything else. Anyway, for the time being, I'm finding that it's easier for me to have two windows opened, one on each monitor.

I did a search without finding an answer as to if it's possible to have Opus open 2 windows by default when it's started, having one window on each monitor. Is this possible to do??


#2

Save a Layout of the two windows, then tell Opus to open the layout under Preferences / Launching Opus / Startup or one of the adjacent pages, depending on what you want.


#3

Doesn't seem to be working for me. I have both windows open on both displays. I go to the main display, #1, and save the layout, named DualDisplay. Then in prefs, Launching Opus/ From Taskbar icon, I select Open from a saved lister layout and I choose DualDisplay.

So, from there I closed both windows of Opus, then clicked the Taskbar Icon on #1 display, but only one windows opens, on the main #1 display, nothing opens on display #2.

I've tried twice with the same result. What might I be doing wrong??


#4

When you save the layout, are you using Save This Lister, or Save All Listers?


#5

I select Save All Listers.


#6

How many listers does it say the layout has under Preferences / Layouts and Styles / Layouts?

What happens if you open the layout explicitly? (e.g. I think there is a layout list in the tray icon context menu.)


#7

It says that the saved layout, DualDisplay has "2 Listers"

I don't know how to open the layout explicitly. When I right click the icon I have pinned to my taskbar on display #1, there are only 4 choices.. Open New Lister, Preferences, Customize, Exit Directory Opus. No option to open a saved lister from there....


#8

OK just now I opened Opus, then went up to the toolbar menu and Selected Settings/Lister Layouts/ and then went down the list to DualDisplay. I clicked on that, and a second window did open, however it opened on display #1. So I ended up with a total of 2 listers opened, but both of them on my main display, and not one on each display...


#9

Under Preferences / Layouts and Styles / Layouts, make sure Open layout relative to the monitor the mouse is currently on is turned off for the layout.


#10

OK, I just did as you advised, however that was not checked, but I made sure anyway. Tried again, but the same result, only one window (lister) opens on my main display when I click the pinned icon on my taskbar..

Just had a thought ( it does happen sometimes...), but I'm going to reboot, and see if that makes a difference.. Back in a few...


#11

No, that didn't help any. Same result as before...


#12

Are you running any sort of window manager or similar third-party software that changes how windows behave?


#13

No, I have not installed any third party software like that. All I did was to attach the second monitor, then go into settings and configure which monitor was #1 and which was #2 and set them to be Spanned. That's all I had to do in Windows 10 to get them both up and running.
I did right click on the Taskbar, and select Settings, and then selected the option where only the windows on my #2 monitor would have icons that showed on the Taskbar of monitor 2.

That's about it. Most everything else is doing as I think it should. For example, if I open my email program from the main monitor, then I drag the window over to secondary monitor, and then close my email program from the second monitor, the next time I open the email program, it opens on the second monitor, just as I want it to....


#14

The Windows 10 display settings don't have a Spanned option. Are you using something else?

200dpi_wc11399_ApplicationFrameHost

Stick to opening the layout via the Settings menu for now, to solve why it isn't opening on the second monitor. Don't use the taskbar button as I suspect you're clicking the wrong thing for what was configured earlier, and it'll be easier to solve that separately once the layout itself is working.


#15

I was mistaken. Like I said, I'm brand new and learning all this dual monitor stuff. The option I selected in Windows 10 was indeed "Extend these Displays".

As far as opening the saved lister layout, the only way I can do that, for now that I know of, is to use the Settings menu, as you advise...


#16

Could you post a screenshot of the layouts list with the one you're trying to use selected, like this:


#17


#18

Are those maximized windows, or free-floating ones?


#19

They are both maximized. I always run Opus maximized, because it's sort of my desktop replacement...

Also, I just found out where I got that "Spanned" from. It's in my wallpaper setting... I knew I saw it somewhere.. But I digress...


#20

Only things I can think of:

  • Something external is forcing the windows to a single monitor. Hard to predict what that might be.

  • Something strange is going on with DPI settings. For example, if the two monitors are not set to the same DPI, or if you have changed DPIs but not yet rebooted, then it can complicate things.

  • One of the compatibility settings has been turned on for dopus.exe, in the Properties dialog.