How to exit dopus - when hung/not responding

I have a vista problem, it sometimes disconnects from local, even though i still have internet. its a vista issue. BUT if i accidentally in dopus click on a mapped drive, i get not responding, and dopus hangs, i would like to quit dopus, and restart it, but it refuses to close, i can "exit" from taskbar, but task manager cant seem to end process it. and i have to reboot. and my machine wont log off/shutdown, i have to power off. i Know this is a vista underlying problem, but if i could kill dopus process, i can at least reboot cleanly.
Any suggestions. :frowning:

If you haven't already, try End Task in Task Manager's Process tab, which is a bit more forceful.

If even that doesn't work then you probably just have to wait for the network request to timeout. When Task Manager won't kill a process like that it usually means the process is tied up in a call into the operating system which cannot be stopped by the process itself or Task Manager. (At least, that is my understanding.) I've seen it happen with Opus and other file managers like Explorer.

thx tried that, i even run taskinfo, which has a better kill process, still no luck. the network request never times out, it just sits for hours. even overnight. I gues i need to find where the lenght for timeout is and change it, i know you could do it in xp, not sure about vista.
thx for your help

If it hangs for that long and cannot be terminated with task manager then I would suspect a buggy network driver or something similar. There's no way anything at the application level (i.e. Opus itself) should be able to do such a thing and the network timeouts should all be much less than an hour (unless they've been modified).