How to let play .mid (midi) thru viewer pane

I added an sf2 softfont to VLC so VLC is capable of playing the midi files .mid is in the list of extensions but i do not get it working to play midi files in de viewer pane. i just get shell icon in the viewer pane. Thank you for the assitance

Finding a DirectShow MIDI codec may be the best bet (assuming no one has made MIDI codecs for the newer MediaEngine/MediaSession APIs, or a MIDI preview handler for File Explorer). I don't know which codec to recommend as I've not tried any of them.

Alternatively, for a quicker solution, you can use a Windows Media Player component to play MIDI in the viewer pane. At least, this works on my Windows 10 machine:

  • Preferences / Viewers / Plugins.
  • Configure MetaPlugin.
  • Turn on the Generic ActiveX line.
  • Add the .mid extension to it.
  • (It's up to you if you want to remove the other extensions, which could result in other audio/video formats playing in the same way if the main Video & Audio plugin can't find appropriate codecs for them.)

Drawback with that method is that Windows Media Player was never updated to handle dark mode or high DPI, so you'll get very small playback controls on modern displays, but the audio does play (at least for the test files I tried).

Thank you Leo, I will try any of these solutions, it's just for quick previewing directories with midi files.

I use a lot directory opus to organise my media files and directory op is excellent for doing this especially the viewer window.

Keep up the good work!

1 Like

Helo Leo,

I tested your sollution, I enabled under Metaplugin Generic AxtiveX 64-bit and added .mid there as there were no other extensions assigned there everything stays clean the controls seems fine on 4K and FHD monitor