How to suppress error message when drive is dismounted?

I have a batch file that, amongst many other things, mounts/dismounts a drive. I often have lister open displaying contents for this drive.

Since 12.8, however, when I run the script in dismount mode, after the drive is dismounted, now I get the lister error dialog window that the folder could not be read. In prior versions it would just navigate to the next available drive or something. I don't care where it navigates to; I just don't want that popup error message.

I've searched through the Settings but did not find any options where I can disable it. Is it possible to do this?


Did you have the folder tree open before but have it closed now? That may cause a difference in this situation, if we're talking about windows that were already open when the drive was dismounted.

It's also possible the dismount notification isn't reaching Opus anymore, which could be caused by a few things (the most common is running the whole dopus.exe elevated, which blocks the messages from being able to reach it, but it can also depend how the drive is dismounted).

You could make your batch file run this command to close any tabs showing the drive before dismounting it:

If we're talking about windows which are opened after the drive is already dismounted, the settings under Preferences / Folders / Auto-Loading may help.

Here's the basic flow of what happens:

  • I run my batch file in "mount" mode and then, for example, the X: drive gets "mounted" (to be completely accurate, I am assigning a drive letter to a volume and in "dismount" mode, I am removing the assignment).

  • Now I open DOpus and navigate to the X: drive and do all that I need to do with the files there.

  • When I'm finished with my work, I run my batch file in "dismount" mode--but the DOpus window is still up and running. As soon as the X: drive is no longer valid, I get the popup error message; in 12.7 and prior, it would just automatically navigate to the next higher available drive and no error messages whatsoever.

If you turn on Preferences / Folder Tabs / Options / Process file changes in background tabs, does it work the way it used to?

I have a feeling it may be tied to that, which is a recent addition. (Off is the new default; on was the old behavior.)

It was already turned on.

By the way, a quick update: It still navigates to the next higher available drive letter; the only thing new is the popup error message modal window.

Could you paste a screenshot of the error message so we can see exactly what it says?

Using the CloseAllTabs command is probably best if it's causing problems.

Additional thought: Is it definitely showing an error for the drive that was removed, and not for the next drive down in the folder tree?

(That can happen in certain situations, although it takes a bit of setting up, or misfortune. It can happen with Bitlocker drives that don't get hidden when dismounted, since they're always there but not always accessible, for example.)

So it's not causing problems, just annoyance that I have to click a button to close that popup modal window.

Your last post made me carefully review the situation and here is the exact flow of the "mount/dismount" process:

  • First of all, there are two drives that I mount/dismount, but only one is ever mounted at any given time;
  • Let's say these drives are X: and Y:;
  • There's also a regularly-assigned drive on my system and let's say it is Z: (and, yes, it is a higher letter than the other two);
  • And, yes, all 3 drives are Bitlocker-encrypted volumes;
  • When the script is run in mount mode, Y: is dismounted, then X: is mounted;
  • When the script is run in dismount mode, Y: is mounted, then X: is dismounted. In the DOpus window, the Z: drives becomes the selected/active drive and its root contents are displayed.

Here is the error message that pops up. I just clicked on the Retry button to see what it would do and the window just closed (it either acted as if it were attempting to retry the Z:\ folder or it did nothing and just closed).


If you mount one drive before dismounting the other, that might avoid the situation, if it's what I think is happening (Opus noticing the drive has gone, and moving to the next item in the tree, which can't be read yet).

It might be something different to what I'm thinking, on the other hand. For me, if I navigate to a bitlocker drive that isn't mounted it triggers a password prompt rather than an error. So you might be seeing something I haven't seen on my own system.

Here's something to try:

  • Turn off Preferences / File Operations / Deleting Files / Automatically select next file after deleting

That will make Opus go up a level if a folder is removed, rather than go to the next item in the tree. So you might end up in This PC rather than the next drive down. I'm not sure if it will help in your situation, but it's worth a try.

I'll have a look to see if we can make the code always go up instead of to the next thing if it's at the root level, too. I don't think it makes sense to read another drive when a drive goes away, like it does with folders. (Edit: We've done that for 12.8.2.)

You know, every time you tell me to test by enabling/disabling a setting, I already have it enabled/disabled! :smiley:

We can now forget about settings, mount/dismount sequence, etc. I discovered something interesting doing some detailed testing that did not involve running my script. My batch file does a lot of things, so to just troubleshoot the problem itself, I was just manually assigning and unassigning the drive letter. This is what I consistently found, so please see if your testing yields the same:

  • If I am maximum one level deep from the root folder of the mounted drive, no issues after dismounting, and DOpus returns to "This PC".
  • If I am two or more levels deep, the popup error occurs when I dismount.

Thanks for continuing to co-troubleshoot; much appreciated!

Something told me to test the folder tree display and I did.

Now I believe that I've definitely narrowed it down: The popup error only occurs when the Folder Tree pane is displayed.

My earlier post still stands, but that testing was done with the Folder Tree pane displayed.

When I navigate no matter how far deep from the root folder, as long as the Folder Tree pane has been closed, then when I dismount the drive, DOpus will go back to "This PC" without any issues at all.

Can you test my scenarios above and see if you get the same result?


Leo, can you run the test and see if you get the same results or different?

I updated to 12.9 and the issue is still occurring.


If I dismount a Bitlocker drive while in a nested folder below it, I seem to just stay in the same place, with no error messages or similar unless I do something that makes the folder tab be read, which then causes a Bitlocker password prompt.

Bitlocker is a bit weird, since "unmounting" the drive doesn't actually unmount it (the drive letter is still there) so there isn't a normal "media ejected" message to respond to. But I don't see the error message you're seeing either.

If it's causing problems, using the CloseAllTabs command I mentioned earlier in the thread is probably the best thing to do. You can add that to your dismount script and tell Opus to close any folder tabs on the drive before it is dismounted, which should remove the issue entirely.

ok, thanks.

The next beta (12.9.2) will have a change to how we handle this which we hope will make things smoother. Should be released in the next week or so.

Excellent and thanks for the heads-up. I'll be sure to test and let you know.

Just installed and tested luck; same issue, unfortunately.