How to view mts files

My mts files don't appear in Viewer.

I'd be grateful for any help in fixing this.

Using Win7 64 bit

Try adding the .MTS extension to the Movie plugin under Preferences - Plugins - Viewers.

You will also need an appropriate 64-bit decoder and splitter for the file format.

See the FAQ on video playback for more detail.

Thank you for your response.

I DLd MPC-Standalone Filters.1.3.1249.0.(x64).zip.
It does not contain a file for mts.
Anyway, I copy all .ax files in MPC-Standalone Filters.1.3.1249.0.(x64).zip to a folder in program files. There were 30 files.
Then I registered all the .ax files.

I went to Preferences - Plugins - Viewers and added ;.mts to the Movie plugin.
The .mts files still will not play in Opus, but the Viewer goes black for a longer time than before.
.mts is registered as a perceivedtype = video.
I guess this is beyond me.
Thanks for helping.

Preferences - Plugins - Viewers and added ;.mts to the Movie plugin.

You need a decoder (codec) as well as a filter.

Try installing the FFDshow (64-bit) codec as that can handle just about everything.

Filters are what understands the structure of the files and codecs are what turns the raw data housed within that structure into video.

DLd and ran:

Now Opus Viewer shows black and flashs Opus, but still doesn't show mts video.
BTW mts video runs in Windows Media Player, but I understand that is 32 bit and I have to also install 64 bit for Opus.

Thank you for trying to help.
This is beyond me.
I'm giving up.

ffdshow_rev3137_20091202_clsid.exe is a 32-bit FFDShow installer.

For Opus on 64-bit systems you should download one named like ffdshow_rev3176_20100102_clsid_x64.exe instead: