Image Conversion Quality Opus 13

In Opus 13 there is a very welcome image conversion utility. Right clicking on an imagage file Opus presents several options (Convert to BMP, JPG, etc) and also "Convert Image..."

When using Convert to JPG, the image quality is severely reduced however when going to the full "Convert Images..." dialogue, the resulting JPG image is at 100% lossless.

Is there a way to have the "Convert to JPG" dialogue default to 100% lossless?



Yes, you can change the context menu via Settings > File Types.

1 Like

Yes, that allows me to set 100% quality however the result is still lossy. A 20.2 KB webp file reults in a 44.7 KB file when using the direct conversion but a 140 KB file when using the dialogue.

The difference I think lies in the "lossless jpeg" option available in the conversion dialogue tab. Is there a "lossless" argument or modifier to enable it?

Lossless JPEG only refers to rotating existing JPEGs without further loss of quality under certain conditions. There's no such thing as a completely lossless JPEG. If you want lossless compression PNG would be a better choice.

I'm sorry but there's obviously a big difference between using the "Convert to JPG" context menu item and the longer "Convert to..." sub dialogue given the significant difference in resulting converted image sizes (44.7 KB or 140 KB). The only difference between the two conversion options appears(!) to be an option for "Lossless JPEG if possible"

Check you don't have any other options enabled (e.g. resizing) when using the dialog. In my tests here the results are identical provided the quality setting is the same.

As I said above, the lossless option only applies when rotating existing jpegs.

I've checked again with a variety of images and it looks like it is now exactly as you state...! I have no idea why I had differing file sizes before as I've never adjusted any of the options under the "Convert Image..." dialogue but now they're identical...
I shall keep on monitoring...

All is good... Converted jpg files are now correct...


1 Like