Issue with RENAME of folders on network drives (12.28.2 onwards, including 12.29)

I am having an issue with renaming folders with 12.29. I rolled back to 12.28 and the problem wasn't there, so I tried a couple of the beta versions and 12.28.1 was fine, while 12.28.2 showed the problem.

The problem is relatively simple

  • Browse a network drive
  • select a directory containing files
  • press f2
  • create a new subdirectory by appending \newname to the end of the directory name. This normally creates a folder called newname inside the directory, and pushes the contents of directory into newname.

As of 12.28.2, the original directory is occasionally renamed to have a numeric prefix.

Any idea's?



Tried with 12.29 on shared folders from two Win10 machines and on FTP-Server running on Android phone - no problems at all.

create a new subdirectory by appending \newname to the end of the directory name

Neat trick, learned something :slight_smile:

1 Like

Yeah, it doesn't happen all the time. It definitely doesn't happen on local disks.

Also, my shares are samba on linux. I'll try and compare with a native windows share and an sftp directory.

Ok, reproduced the issue on a Windows 10 shared folder.

I've also suspect the problem happens more if the directory you are renaming happens is be open in another pane/lister/tab. Normally directory opus doesn't care, it does the rename and updates all the panes.

I was able to reproduce this, and am currently testing a change which should improve things.

Can't see anything in the 12.28.2 changes that should have affected it, but maybe something about how the OS handles network folders and locking changed, as it does seem to be different with them vs local drives. (That said, I can also make the problem happen with local drives via slightly different steps.)

Having something (another tab, or File Explorer, etc.) looking inside the folder which is being moved around/renamed seems to be key. I am not sure why that is making the OS fail the operations now (or if it always did and nobody noticed before now, perhaps) but I think I have found an alternative way of doing things which works.

1 Like