Jpg file does not open

jpg files are set in File Types to open with Nero, but nothing happens when I click on the file.

When I right-click and select open with Nero, the file opens fine.

What could be the reason?


Hans L

Could you show us your filetype settings for jpegs?

Okay. And here is my real path (copied, not typed):

C:\Program Files\Nero\Nero 7\Nero PhotoSnap\PhotoSnapViewer.exe

You have the Open command set correctly, which works from the Selected File Type Context Menu. But we need to see the Events Tab in the File Types dialog, which governs double-click and my other mouse events.

Okay, here that one is. I havea strong feeling it does not look good.

Hans L

But then, again, it looks like this for a lot of extensions that work when left-double-clicked.

Hans L

I don't have anything configured there either. But at least we know you have nothing there that would cause an issue.

Filter preferences for "internal picture viewer" and ensure that option is set to all recognized pictures.

"Filter preferences for "internal picture viewer" and ensure that option is set to all recognized pictures."

What I did was to go to

Setting + Preferrences + File Operations + Double-click on Files, and I unchecked :Use internal picture viewers for".

All is now well. Thank you for your help!!!

Hans L

That doesn't explain why nothing happened before, though. It should have opened the Opus image viewer.

You are right, Leo. When I opened the image viewer manually, and I clicked on the jpg file, the image was shown in the viewer. But, it did not open automatically when I clicked on the file.

And, the other thing is that the settings must have been changed with the update. I guess that the changes to the Preference menu were considerable, and that the use of the internal viewer was set as default.

Well, as I do not use the internal viewer (not enough real estate on the monitor for file tree and lister and viewer), I am now okay, but perhaps there is some other settings somewhere that prevented the automatic opening of the viewer. I'd be glad to look if I knew where.

Again, thanks for your and Ken's help!

Hans L

The internal viewer opens as a separate window when you double-click files so there's no space issue.

Anyway, if you're happy now then there's no point investigating further, just seems odd that nothing was happening on double-click with the settings as they were before.

Yes, it is funny that the viewer did not open. But as I am sure it works for you, it is not a bug, so if, in the future, I need the viewer to open automatically, I'll be back on this list :slight_smile:

Hans L