GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Library.dll not updating to 12.19

I have tried both the auto download and install and manually downloading and installing 12.19.

In both cases dopuslib.dll and dopuslib32.dll do not get upgraded to 12.19 they stay as 12.18 builds. This causes DOPUS to complain and fail.

12.19.2 also has the same problem. The digital signatures are reported as OK.

I'm using Windows 10 v1909

Did you try rebooting after installing?

Thanks for the reply Jon, yes I have rebooted the PC both as a warm and cold boot.

I haven't tried installing using Run as Administrator privileges, I wonder if that would work?

The installer should ask for administrator privileges automatically when you run it. Did it not?

No, it never has for me.

I have solved the problem, I renamed the two LIB files and then attempted an install. This has worked.

It is worth noting that the install program (before the LIB files were renamed by me) did not create a zzzTmpOldFilesNNNN folder. Currently the index for those folders is at 1111, is it possible that four digits is the maximum suffix allowed in the update program and therefore was unable to make a new folder?

zzzTmpOldFiles1111 contains the library files for 12.17 .

It sounds like you haven't rebooted the machine in several months.

Those folders should be cleaned up after a reboot.

If there are 5 of them already, the installer falls back on the old method where you need to reboot to replace DLLs, to avoid creating more of a mess in that folder. In that case, you should have been prompted to reboot at the end of the install:

If you said No to that and then tried to launch Opus, you should have been asked to restart the machine then as well:

Did those prompts appear or did something else happen?

Once you restart the machine, everything should work, and the zzzTmpOldFiles folders should also be removed automatically. (If they are still there after a reboot, you can delete them manually, which should also mean installs done afterwards work normally.)

Have you turned off UAC or set it to never prompt? Or are you launching the installer from a process which already has admin rights?

Hi Leo,

  1. PC is booted everyday and powered off.

  2. I did get the restart dialogue (and restarted).

  3. At logon I did get the mismatch message which read 12.19.2, 12.18.x, 12.19.2 .

zzz folders are still there and 12.18.x has bot been backed up.

  1. I do have UAC set to never prompt.

I have attached a snipshot of the current folder contents. DOPUS is now working after I manually played with the library dll's.

I do have Acronis Backup 12.5 installed which used to use File Explorer and DOPUS, but now it is browser based and no context menus anymore it may be a red herring, the AV is Avira at this moment.

As no one else has reported this problem on the forum, I must be an outlier.

All those .rra files also indicate that the delete/replace on reboot function of Windows either isn't being run or isn't working for some reason.

Note that if Quick Boot is enabled in Windows — and it's enabled by default despite not speeding things up much and being a bug factory :slight_smile: — then shutting down and booting up the computer won't do the file replacement; only a restart will, which is counterintuitive. But if you've restarted as well, and still see those files, then something is wrong with the Windows install.

Thank you for your help Leo, so, It is OK to delete all the x.rra files as well?

It is possible my W10 installation is not as clean as it could be as at one time I did subscribe to Windows 10 beta editions and stopped that when the big Windows 10 update came out a few years ago.

Any .rra file is safe to delete if it's still there after doing Start > Power > Restart.

If it helps diagnose things, there are some command-line tools which list any file/folder moves/deletes which are waiting for a reboot: