Lost sounds

I recently installed DOpus overtop of my previous DOPus 9.x installation. All worked great. My previous settings and options transferred nicely. I made some adjustments with the new toolbars and all, and was very pleased with the new version. That installation was a little over a week ago on an XP system. Today Windows signaled it had some updates for my system, which I thought had been downloaded and installed previously. Never the less, I let Windows redownload them and reinstall them, then I rebooted, as instructed by Windows. After rebooting, none of my DOpus sounds played. Granted, I only had a few sounds playing, and using DOpuus without the sounds is not detrimental to the program's performance, but I would like to know what happened to them. I have opened the DOpus options applet and noted that all of the sounds I wanted to be played were checked. I checked a new one, closed the options. Closed Dpus. Reopened DOpus. Silence. I opened the settings-sounds again, unchecked the one I had checked before, saved it again, and tried reopening DOpus agina. Silence. I tried rebooting Windows. Twice. Silence.

Although I use sounds very sparingly, all of other program sounds both for Windows itself and for applications play normally.

The ones I had checked for DOpus to play were for the first time DOpus opened after starting my profile afresh. Thereafter, whenever DOpus would open there was a ding, and whenever it would close there was a dong. In my C:\Program Files\GPSoftware\Directory Opus\Sounds folder, I can find the ding and dong wave files, but the two-tone opening wave file has been changed to something vastly different. The original sound is gone. In my C:\Documents and Settings\User\Application Data\GPSoftware\Directory Opus\Sounds folder I can, again, find the ding and dong wave files, but no opening sound wave file of any kind.

In my Sounds and Audio Devices applet, under the Sounds tab there is no list of any DOpus sounds at all, either in my saved sound scheme or in the Temporary sound scheme.

Do I have to reinstall DOpus to have the sounds become available in the sound schemes? Can I tweak my Registry to get the DOpus sounds to play as they did previously? And where did the old opening sound go? Was it held in a Windows loaded sounds subfolder, as in-use icons are? If so, I can't find the deleted files using my Undelete program. They're gone.

Thanks for your help.

I found the missing sounds. I hadn't viewed and played the individual sounds in the DOpus preferences. They were all available and accounted for, albeit not all in DOpus folders. That's okay. I now know where they are. However, none of them play when performing the linked action in DOpus. The Enable sound events box is ticked, so that is not the problem.

Maybe you've muted the Opus process in the Windows volume mixer?

In this XP system there's a Volume Play Control, but no Volume Mixer. I didn't change any setting — just rebooted. My first thought is that Windows reset some key in the Registry, but that could just be my paranoid prejudice. No other program sounds were affected — Just DOpus's sounds. The Creative Audigy sound controls don't seem to have any links to DOpus, and I just listened to some new CDs under headphones, so I know the sound system is working awesomely. I can't hear anything now, but I know there was no problem with the sound system.

Do the sound files play through Windows Media Player (or another program that's not DOpus) ?

Have you tried this now? Sorry, probably a dumb question, but it isn't clear to me if you have actually tried to play the sound files within "Preferences>>Sounds".

Tried disabling/enabling again?

Tried a different sound?

Tried adding an event that you don't normally use?

Thanks for your replies.

Using DOpus to locate the sound files in their folders, I have double-click on each WAV file, and each one plays normally. If I go into DOpus Preferences and open the Sounds section, all of the sounds I have selected are listed with the correct paths. If I then highlight each one of the events and click on the play button for each one, each sound plays normally. There is no problem with the sound files themselves nor with their location paths as set forth in the Event Sounds list.

I have unticked and reticked the Enable Sound Events box, closed and opened DOpus with that box ticked and unticked, rebooted the system several times. I may try rebooting yet again.

Would reinstalling DOpus ontop of my present installation set things aright, or just muddle things up further? Other than the sounds having gone silent, DOpus is working great, and I'm a little apprehensive about reinstalling and having something else get broken.


Which soundcard are you using?

Jon — One of the files is Windowx XP Hardware Inseret.wav found in C:\WINDOWS\Media. The file has nothing to do with DOpus directly. I have opened it in Sound Forge, an audio editing program installed on this system. It plays normally. In the same program I have opened both ding.wav and dong.wav, both in C:\Documents and Settings[i]User[/i]\Application Data\GPSoftware\Directory Opus\Sounds. Both play normally.

Sasa — My sound card is Creative Sound Blaster Audigy 2 ZS. It's been in this machine since around 2002. There has been a current version of DOpus on this system continuously as versions have been released. (For the present release, a bit later than the normal upgrade time frame.) Sounds have always played normally while using DOpus. Nothing has changed in the sound card, its driver, or its settings for some time (years?).

The only thing that has happened since installing is that I finally installed Windows XP SP3 so that I could install DOpus Never needed SP3 before. Never wanted it before. But now I have it. I was told SP3 would be simple and painless to install. Not exactly. Windows must have deleted or overwritten all of the more recent updates installed over the years on this system. Windows listed 99 updates to install. I let it install them. Took a while. Then I rebooted. Then I installed DOpus Unlike Windows, that was painless and easy.

Within a day or so, Windows found yet another load of updates. Many names looked like they had been part of the 99 I had just finished downloading and installing. Shaking my head, I let Windows download and install the new batch of updates, then rebooted.

It was only after the second round of Windows updating and rebooting that I lost all sounds in DOpus.

Ok, I have an Audigy and had a similar problem, too.

If you reset everything in Audioconsole (esp. CMSS 3D) will it work then? If so it is a driver problem and will work until you change audiomode/settings again (2.1 to 5.1 or something else).

Interesting Sasa. I read your reply just before I had to go out. Now I'm back, but I won't have time to really play with the settings until later. Why did you think to alter your Audigy settings? I haven't even looked at my settings for years. Everything seems to be working normally. Were you having audio problems with other programs?

Suddenley after years there was no sound anymore (as said not the same prob, but mabe the same cause). Looking in Google (thanks Leo!) this playback-bug is known with Audigy soundcards. Playing with audioconsole solves it, but only temporarily for me as I often switch between different modes. It's reproducable.

Thanks for your suggestion Sasa. I tried tweaking some of my Audigy settings. Didn't help my DOpus problem, but the new settings will work better on my system.

Although I am the only one who uses this system, in the past I had it set up for multiple users, one being the Administrator account. I logged in to one of the other user accounts and opened DOpus. No sounds. However, opening the preferences, I found that no sounds had been set up. I set four sounds, for open an close lister and sart and shut down DOpus. After setting them up, all of the sounds worked normally.

This tells me there is nothing wrong with the DOpus program itself or with the OS or with the hardware. The problem is limited to the settings within my user account. I tried using older saved lister settings, previous to the installation of DOpus 10, in the hopes that my present settings are corrupt, but no sounds played with the older lister settings, either. This leads me to believe it is not a setting in the preferences, but somewhere else specific to my user account.

I got excited last night when I found a GPSoftware key in the Registry that ended in "silent". but it turned out to be for a silent uninstall.

This problem is becoming perplexing.