Menu buttons in File Type context menu?

As above, is this possible? I understand that they'd only show in Opus and not in Explorer, but seems you can only use menu buttons for toolbars & Opus menus?


What you're looking for is in the File Type editor when you are editing a Context Menu, the New... button lets you create a new context menu action which you can then use the Type: dropdown to set as a Sub-menu (not supported in Explorer). So - you create the sub-menu just as if you were creating a new action to run a command, in case you were expecting to see some separate button all-together for a New Menu... or something like that.

Thanks, but I'm actually after a "menu button" not a normal menu - i.e. a button where if you click it it performs the default action, but there's also a drop-down to do other things:


Menu button:

Oh, yeah - you did say menu "button". Sorry - but no, we don't get those in Opus Context Menu's...


Sounds like a feature request :slight_smile:

Sub-menu 'Buttons'...

leo & team... could I request this goes on your todo list?

Just posting ideas here is enough for them to be considered. No need to do more.

Cool, thanks :slight_smile:

That's in 12.2.7 beta which you can download now.

Ok that's amazing. You're definitely the most responsive development team I've had the pleasure of dealing with. Thanks again!

I can confirm that this works in 12.2.7... kinda...

I'm getting different behaviour when I right-click a folder in the tree vs. the file list - some items are disabled.

[li] Tree

[li] File list


For info my folders file type menu is set as shown:

Nevermind, fixed it by specifying the proper path:

I think that's a separate issue - or are you saying it used to work prior to the menu button stuff?

I think it's unrelated - I think "CLI DOSPROMPT=selfolder" doesn't seem to work if the last thing you selected was an item in the tree, although I had not tried that prior to 12.2.7. But I'm very happy with how the File Types menu button is working.

Sorry, by "last thing you selected" I mean "the thing you right-clicked on".

That should work in the next update.

Sorry to be a pain, but I've also noticed that the menu button looks different depending on if the item marked as 'button' is shown/hidden.

Here's my File Types setup:

With a file in the clipboard, it's a menu button:

With some text in the clipboard, the Paste item vanishes and the menu item becomes a normal cascading menu:

In comparison, a normal toolbar menu "works ok":

With a file in clipboard:

With some text in the clipboard:

The toolbar menu items don't have "usesel" where the File Type ones do.

You can see also that with a file, Paste and Paste Shortcut are both enabled and work, but with text in the clipboard, the File Types menu doesn't let you paste it at all, although I believe they should behave the same.

Further to this (and perhaps to bump it, sorry!), it looks like "clipboard paste usesel" behaves differently to "clipboard pastelink usesel".

A button with "clipboard paste usesel" will make itself invisible if there isn't a valid selection, and "clipboard pastelink usesel" will make itself disabled.

The first button making itself invisible appears to mess up the File Types menu button.