GP SoftwareTwitter
Opus FAQsManualCommandsObjects

Metadata & Movie Properties


#21

As I said previously, Directory Opus does NOT display FOURCC, Data Rate, and Bitrate columns’ metadata for .mkv files; .mp4 absolutely fine, though. ALL previous registry fixes in this thread tried, but no difference made whatsoever. I am using 12.7.4 with the latest Windows 10 Professional (64-bit) insider build. A solution to fix this long-time frustration would be very much appreciated, experts. Thanks.


#22

Those are MKV files in 4wd's screenshot, so it definitely can work.

But it's also something which can be broken by different video software taking over the involved DLLs and registry settings, which can be complex to work out. That's something we're thinking about for a future version, although we have no concrete plans yet.

For now, an easy solution, if the columns aren't working on a particular machine, is to import Explorer's columns into Opus. Then you get exactly the same as in Explorer. The Video length, dimensions, framerate, definition columns script add-in does this for several video related columns, and could be expanded to cover others that you need.


#23

DOpus 12.6 (10 months ago)

DOpus 12.7 (<5 months ago)

And 12.7.4 in my post above ... DOpus has shown the correct info through the last 10 months (and probably since it's first version after Windows 10 came out).

You have yet to say whether Explorer shows the correct (or any) info and whether or not you have (or had) any extra codecs (eg. ffdshow, XVID) or splitters (eg. MadVR) installed on your system which are more likely to be the problem.

Run the Windows System Information program and see what Audio/Video codecs are installed:

Download NirSoft's InstalledCodec and run it. It will show what codecs and filters (eg. MadVR) are installed.

I had VEGAS 14 Pro not starting because of codecs (or DirectShow filters) installed, my solution was remove ALL codecs/splitters and perform an In-Place Upgrade of Windows 10 which cleared it all back to default.


#24

File Manager (as it's called in Windows 10; not "Explorer") does NOT display the aforementioned columns' information, either, and has no such option from what I can see that equates to the FOURCC column I'm talking about so I can see H264 and HEVC files at a glance.

The script Leo posted will not address the issue for this reason. I'm sure you are correct, though, in stating that it must be other installed codec-related software that is preventing this information from being shown; it is obviously a question of finding out what and fixing it without removing the functionality of such software. I hope the DO team implement some sort of fix for this in a near-future edition that will prevent this from happening and keep the issue from lurking its head again. Thanks for your time and support in trying to help me resolve this annoyance. I'll post an update on any developments that solve the issue, if found.


#25

The file manager in Windows 10 is indeed called "File Explorer" and not "File Manager" as I had said in the previous post. Other things checked accurately as far as I have worked out so far, though.


#26

If it's also broken in File Explorer then it's not something we can fix in the near future. Something is broken in your Windows install, not in Opus.

Further in the future, we might bake-in components for handling some of this so that Opus does not need to use the Windows components (and any third-party ones that are also installed) for the most common video types, but that's a more long-term plan.

PS: Don't forget to link your account, which will give a boost to feature requests like this.


#27

If you download and run the program InstalledCodec I mentioned earlier you can sort by the Installed/Modified column which might indicate what you did that was at the approximate time it stopped working.

You can also use it to disable/enable individual codecs/filters in an effort to isolate the problem, not sure how successful that will be compared to uninstalling.


Show resolution for mkv
#28

One non-obvious thing is that the built-in columns in Opus depend on the Movie viewer plugin. If you have disabled that, due to a preference of using a different plugin/activex for playing movies in Opus, then it will also disable a lot of the movie metadata columns.